Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Visual/Navigation (http://www.jeepgarage.org/f186/)
-   -   05 Wk Radio issues NEED HELP!!!! (http://www.jeepgarage.org/f186/05-wk-radio-issues-need-help-49896.html)

Bsemig 11-05-2012 11:31 AM

05 Wk Radio issues NEED HELP!!!!
 
I have a 2005 wk and recently i trusted my younger brother to install some subs and an amp. Well everything was fine until he hooked everything up to the radio and now nothing works. We checked EVERY fuse and none are blow. after further testing that the two power (red and orange) wires are completely dead. i have no idea what can be causing this. When we try working on it my whole jeep goes nuts and throws up check suspension, check elec. Brake system. Then after we quit testing stuff everything goes back to normal but still no power to the power wires. PLEASE HELP!!!!


Laredo 4.7L V8.

Milous 11-07-2012 06:11 AM

Re: 05 Wk Radio issues NEED HELP!!!!
 
Quote:

Originally Posted by Bsemig (Post 707184)
We checked EVERY fuse and none are blown.

Underhood fuses, too? Specifically #27/28 shown here: http://www.wkjeeps.com/misc/wk_power_module_01.jpg

What exactly was hooked to the radio, nothing should have been hooked there except for a speaker lead to the sub amp.

Bsemig 11-07-2012 10:26 AM

Re: 05 Wk Radio issues NEED HELP!!!!
 
im not sure what it was that he hooked up somekind of crossover thing to be able to have rca's he connected it to what he thought was the speaker wires but i have the premium sound package in my jeep. i will double check those fuses but im pretty sure they are good.


All times are GMT -5. The time now is 07:35 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community