Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Urgent advice needed.... Lots of "service" messages and now it won't turn off (http://www.jeepgarage.org/f181/urgent-advice-needed-lots-of-service-messages-and-now-it-wont-turn-off-50840.html)

augusta 11-27-2012 08:18 PM

Urgent advice needed.... Lots of "service" messages and now it won't turn off
 
started with a "service 4wd system" but didn't notice any noise or issues. drove the 30 miles home. turned key off. "service electronic brake system". and "damaged key" and some others... and the dash is staying on and headlights as well and I can hear a fan running under the hood. Jeep is turned off.

Tried a different key. Tried starting backing up (worked), forward park, off. still on.

Assume I should unhook the battery?

Please advise as soon as possible?

I THINK I might have a clock spring issue but only symptom is rubbing noise when turning (in steering column) and twice in the last 3k miles since bought used with 75k miles the entire dash has shown all warning lights when making a 90 degree turn. Ugh.

Thanks,

Augusta

bill_de 11-27-2012 08:51 PM

Re: Urgent advice needed.... Lots of "service" messages and now it won't turn off
 
I think you should have disconnected the battery first, and then found an internet forum. ;)

augusta 11-27-2012 08:56 PM

Re: Urgent advice needed.... Lots of "service" messages and now it won't turn off
 
LOL!!! I had to come in the house to get a wrench anyhow and was hoping it would be off by the time I got back to the garage... Plus I'm a fast typer. ;-)

Negative battery terminal has been disconnected for about a half an hour now.

Any ideas of whats going on? Anyone? Please????

augusta 12-06-2012 11:13 PM

Re: Urgent advice needed.... Lots of "service" messages and now it won't turn off
 
Does anybody have ANY ideas on this? I had the battery tested (advice of dealership) and its fine. The jeep has done this two more times since my first "urgent" plea for help 9 days ago on your site. My dealership is about an hour away and wants $40 to $90 to diagnose. I haven't been able to get it there for an appointment and except for these three incidents it has not missed a beat. The dealership also said it would not be a clock spring issue since my cruise control works.

Please? Anyone?


All times are GMT -5. The time now is 03:56 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community