Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (
-   Troubleshooting/Problems (
-   -   '04 WJ 2.7 CRD not starting - SKIM or other issue?? (

arievanbekkum 11-29-2012 08:57 AM

'04 WJ 2.7 CRD not starting - SKIM or other issue??
Hi, a week ago, I drove my wife's 2004 2.7 CRD Overland (bought new, now mileage: about 240000 km) and stopped the car because all the gauges on the instrument panel went on zeros and all lights started burning. I've had this twice before, several weeks ago, then it disappeared after restarting the car.

But this time, the car started, ran for about 2 seconds and died. This happened several times. After this, it didn't start at all anymore, only all lights burning and gauges on zeros. Central locking doesn't work, power windows don't work.
I recharged the battery overnight, didn't help a thing. The car was towed to a diagnose specialist, who's not overly familiar with Jeeps. He pulled out an error code P1685, which is invalid SKIM key. He told me the immobilizer system probably has to be replaced by the dealer.
I tried both keys, that makes no difference.

The AZC fault codes I read in the climate control display are:
11 = Engine air intake temperature bus message missing
12 = Country code bus message missing
26 = Engine coolant temp bus message missing
27 = Vehicle speed bus message missing
28 = Engine RPM bus message missing
29 = OAT bus message missing
30 = Display intensity bus message missing
31 = VIN number bus message missing
32 = Raw OAT buss message missing
43 = Engine air intake temperature bus message missing
44 = Country code buss message missing
63 = VIN number bus message missing
64 = Raw OAT bus message was missing

43, 44, 63 and 64 showed only in the first loop, after that, they were not shown anymore.

I've read on some forums that it could be the crankshaft position sensor, that it doesn't necessarily shows a fault code when it's not functioning and that the engine management computer goes nuts and gives an invalid key.

What do you guys think?! I don't wanna tow it to a dealer yet (that's 80 km away and they'll tell me half the car should be renewed) before understanding more about what's wrong.

Hoping you can help and looking forwards to read your replies!

Frango100 11-29-2012 03:04 PM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
Most of us are not familiar with the CRD versions, but lets see what we can do.
Seeing all the faults you have in the AZC system, it seems that the PCI data bus is down for whatever reason. The engine controller should get a signal over the PCI bus from the SKIM that the key is ok. So any component connected to the PCi bus could be the culprit. I think that the only way is to disconnect each one by one and see if the instruments come back to normal indications, which means that the PCI bus is back again.

arievanbekkum 12-07-2012 09:09 AM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
Hi, thanks for your reaction.
How can I disconnect each component that is connected to the PCI bus? Also, when unlocking the car with the remote, only the drivers door unlocks. None of the power windows are operational..
The car is standing outside (the fact that it's snowing doesn't increase the fun) in the yard. Is it possible to disconnect those components without lifting up the car?

I placed a new battery already to make sure that is not the problem, but unfortunately it didn't help anything.

Frango100 12-08-2012 06:04 AM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
Strange that only the drivers door unlocks. The receiver for the remote locking is mounted together with the door module on the right hand (passengers side) door and via the PCI bus the drivers door is unlocked. Or is it a right hand driven jeep?
No need for lifting the jeep to disconnect the PCI bus from each component, you just have to get to each component and disconnect the connector(s). Not sure now which components are connected to the PCI bus, but that are at least quite a few.
PCM, SKIM, AC head unit, BCM, Anti skid module, the door modules, instrument panel and more. I know that there is a connection block somewhere below the steering wheel, where all components PCI bus connects to and where you could disconnect one by one.

Hybrids 01-03-2013 02:41 AM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??

Shameless first post and thread resurection.
We have a 2003 WJ 2.7CRD in England, mostly for commuting, moving our dogs around and occasional tow car for our race car.

I found this thread while researching an identical issue with our Grand Cherokee.

Ours had been in with a local garage to have the injector seals replaced, 24 hours later the symptoms started and the Jeep had to be towed into the garage.
When it would not start I tried to obtain the codes using the ket on/off method with no luck.
They are now thinking it is an immobilisor issue and it is due to go to Jeep today, (I beleive they already tried a Cam Position Sensor)

Arie; what was the outcome with yours ?


LionheartUK 01-05-2013 01:55 PM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
had something similar with our last jeep, turned out to be one damaged wire under the bonnet on the right (looking from the front) at the back, that loom is apparently prone to damage...

arievanbekkum 01-07-2013 08:48 AM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
Hi Gareth,

We got our Jeep back last Friday and the problem was a damaged wire somewhere under the bonnet. At Jeep, they were not able to locate the exact wire that was damaged (half the engine compartment was taken apart), only a certain group. So, the renewed the wiring from this whole group.
The car is up and running again. Costs: about 370 EUR
And it had nothing to do with the immobilisor.

New problem: overhead information center is not working at all (temperature, avarege fuel consumption, distance until next service, etc.), is all on "--". Probably something was not reconnected.

Remaining problem, which we have a problem with already for over a year: around 90-100 km/h (RPM around 2000) the engine is unsteady and there is a big lack of power. The car hardly goes any faster then 120-130 km/h, while before we easy reached higher speeds. Fuel injectors have been cleaned and repaired, gearbox is obviously completely in order, we have no idea what it is. It might be the computer, but who knows..

Frango100 01-07-2013 05:21 PM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
Would be interresting to know which wire was damaged, i would imagine that it was a PCI data wire. Was the wire broken, or was it shaved through (probably the last)
Regarding the EVIC which shows only dashes, it probably has to do with this same PCI data wire, which probably is not connected and thus canīt send the required information to the EVIC.

Hybrids 01-08-2013 05:52 AM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
Thanks Lionhearted and Arie
My local dealer came back to me this morning with what they "think" the problem is...

Gear selector ! And it's approx Ģ600gbp plus fitting.

When pressed for diagnosis information the service rep stuttered and said " that's what the tech thinks it is" and then recalls a recent vehicle with vaguely similar issue of not starting but non of the dash lit up or locking and window issues, that turned out to selector.

At the moment I am only into the dealer for 1 hours labour, I have spoken to the garage who did the injector seals ( who is a long time family friend) and we may pull the car back to his garage and pick through the loom looking for the issue. I am tempted to start at any loom around the gear selector as that would appear to be favourite, closely followed by the loom at the back right of the engine bay.

Arie: the loom section they have replaced, what is it described as ? It could be a starting point, the part numbers a probably different due to LHD vs RHD

Thanks again everyone


Hybrids 01-12-2013 04:33 AM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
currently at the garage working our way through the car.
No obvious signs of damage to the loom, but that does not rule it out.

What is strange though, when the gear selector is unplugged all the gauges read correctly, the elec windows work as does the central locking. Plug it back in and they stop working.

As mentioned previously, i was not able to get any codes via key on/off. With the gear selector unplugged I get P1242 & P1652 which appear to be CAN related codes, possibly due to the selector being unplugged. When I plug it back together the key on/off will not work.

Pin 2 of the OBD plug, when unplugged I am getting 1.1v, when it is plugged in it drops to 0.15v.

So there is still something pulling pin 2 down from 2.5v

Does anyone have a component location pic so I can make sure I disable all the components in my search, though deep down i think it is wiring related.

Lionheart: did you change the full engine loom ?

Frango100 01-12-2013 06:32 AM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
1 Attachment(s)
On the CRD the Selector Lever Sensor Assy (thats what jeep calls the gear selector lever assy) also has a connection with the PCI bus. If you disconnect this assy and the PCI bus returns, you have found your problem.
However the question is what the PCI bus voltage should be. Have a look at the threads from Father Theresias, who is struggling with PCI bus problems ( on a 4.0 however, but the bus principle is the same), where he mentioned that the bus voltage should be 7.5V. After some searching we found that there is a bus disconnect plug under the stearing wheel, however i wonder if the 2004 has it like this. This plug just has a shorting end cap, which connects all bus wires together. (see attached picture for location of the diagnostic junction port)
I think that the stealer should have a special tester which they can connect overthere to read each component separately, however still some components are connect together. This plug is shown on the 99/03 wiring diagrams, but i canīt find it on the 04 diagram anymore.

Hybrids 01-12-2013 06:46 AM

Re: '04 WJ 2.7 CRD not starting - SKIM or other issue??
Back home now with a small update...

With the selector plug unplugged I decided to unplug sennsors I could see, first to hand was the cam sensor, I had unplugged this previously when I could get no codes, with this still unplugged I then unplugged the fuel rail sensor.
Went back to check voltage and codes and I had a new code P1131 (fuel rail), but I did not have a Cam Sensor code, despite it being unplugged.

I plugged them both back up (after rerouting the cam sensor wire to make access easier)

With the selector still unplugged I put on the ignition (gauges work as they should)
Plugged back in the selector
Engine started :confused:

After a few seconds the gauges dropped and the panel lit up like a christmas tree, but kept running.

While running I unplugged the cam sensor, it kept running (as I half expected), plugged it back in and it cut out a few seconds later.

try to start and it runs for 2-3 seconds and dies.

Unplugged the selector plug again, put ignition on, plug back in, fire it up.
Engine runs and no gauges.

Despite the key role the selector is playing, I am not 100% sure it's that, I will try to locate a s/h one now I have the part number just to eliminate it.
Apparently the garage DID NOT fit a cam sensor, despite that being my original request, bit pissed about that as I had considered that eliminated, one has now been ordered and will be fitted Tuesday.

More updates to come, I am off to play with my race car now for some stress relief

All times are GMT -5. The time now is 11:40 PM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community