Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   2000 Laredo w 182,000 miles losing antifreeze (http://www.jeepgarage.org/f203/2000-laredo-w-182-000-miles-losing-antifreeze-52049.html)

Bushpw@aol.com 12-26-2012 10:08 PM

2000 Laredo w 182,000 miles losing antifreeze
 
Well maintained, Laredo, one owner, never overheated losing antifreeze. Not the radiator or radiator cap. I think heater core is bad because windows fog up and sweet smell. No sign of antifreeze under vehicle. Engine runs great. Could it be the heater core? Or isn't a head gasket?

I appreciate any advice an suggestion for a good independent shop in the area.

Scottina06 12-26-2012 10:35 PM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
WELCOME to the JeepGarage family!!!


***moved to the wj forum for more exposure!****

Frango100 12-26-2012 10:36 PM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
Welcome to the garage.
Have a look under the passengers side footwell carpet, if the heatercore leaks, it will be wet overthere. To change the heatercore, the whole dash has to be removed, so will be quite an expensive repair due to the many hours of labour.

Bushpw@aol.com 12-26-2012 10:45 PM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
Carpet is dry. If not leaking there and no visible antifreeze, does that point to a head gasket or intake gasket as the problem?

Frango100 12-26-2012 10:52 PM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
Did you look underneath the carpet?
Is there any white smoke coming from the exhaust with the engine warm? How does the oil look on the dipstick and the oil filler cap?
Is the sweet smell inside the cabin?

Bushpw@aol.com 12-26-2012 11:10 PM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
I peeled the carpet back and carpet and floor are dry. Dipstick oil looks normal (no water or milky look), dry under the oil filler cap. I will check the exhaust tomorrow. Have been losing antifreeze for a few months. Lost about 3/4 inch in the reservoir in 1 hour of city driving.

Frango100 12-27-2012 05:53 AM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
But where is the sweet smell, inside the jeep or outside?

JeepTechGA 12-27-2012 09:01 AM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
Its a heater core if U see fog on pass side windshield and sweet smell its is from lower half of heater core. If u see coolant coming of of the drip tube under the hood its a real bad leak.

Ben_02WJ 01-03-2013 12:19 PM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
I just had to replace my heater core. Like you I was loosing small amounts of antifreeze as seen in the reservoir. I did not get any sweet smell in the cab or wet carpet. I finally decided to do the heater core when I started to get a little fog on the windshield after months of no symptom other than the small fluid loss. When I finally removed the heater core it was leaky but not enough that the condensation drain could not handle it...

Bushpw@aol.com 01-03-2013 10:18 PM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
The heater core was leaking. I bypassed the heater to find out If that stopped the loss of antifreeze. Unfortunately no - still lost 3/4 inch in the reservoir after a 10 mile drive. Does that mean it is leaking into the cylinder?
Dipstick oil does not look milky.

Frango100 01-03-2013 11:42 PM

Re: 2000 Laredo w 182,000 miles losing antifreeze
 
If the coolant leaks into a cylinder, you normally smell it at the exhaust fumes or even will see white smoke coming from the exhaust with the engine hot.
Did you check for air bubbles in the overflow reservoir when the engine is hot?


All times are GMT -5. The time now is 11:45 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community