Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   2004 WJ Laredo 4 WD Not Working (http://www.jeepgarage.org/f203/2004-wj-laredo-4-wd-not-working-52313.html)

Jasiu 01-01-2013 05:05 PM

2004 WJ Laredo 4 WD Not Working
 
I have a 2004 WJ Laredo with Selec-Trac. I don't think the 4wd system is working. Going up a small grade in my alley xcauses me to spin whether I am in 4wd or not. I can not shift the transfer lever into either Neutral or 4 Lo. I can get it into 2wd 4 Part Time and 4 Full Time. Any ideas as to what is wrong?

Frango100 01-02-2013 07:16 AM

Re: 2004 WJ Laredo 4 WD Not Working
 
Difficult to say what exactly is wrong, but it seems to be in the T-case itself at least. When you say the wheels spin, you probably talk about the rear wheels only, isnīt it? I would first check if the T-case shift lever/cable is not binding somewhere or mis rigged. Then check T-case fluid level and check for any debris in the fluid.
I donīt know how long you have this jeep, but some guys just remove the front propeller shaft when a problem with the shaft joints arrises. Just have a look if its still there.

Jasiu 01-02-2013 09:31 AM

Re: 2004 WJ Laredo 4 WD Not Working
 
Well, today its working fine. Stopped down at my mechanics today and he stated that with all the snow we've gotten something may have gotten frozen and thawed out


All times are GMT -5. The time now is 07:04 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community