Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   transmission selector lights (http://www.jeepgarage.org/f203/transmission-selector-lights-52744.html)

kennytheone 01-11-2013 08:22 AM

transmission selector lights
 
hi there new to forum and i have a problem on a 2004 2.7 grand cherokee . start car up no drive car just revs. then i noticed that the lights next to the auto selector leaver where not a light after a while they came on . once they where on car now drives as normal drive for awhile pull over then turn off . turn back on same problem wait 5 -10 minutes lights back on and once again can drive.
so i am thinking there a loose connection some where but not sure where to look
i have check for code only code showing was a skim key code p1685 which i cleared no codes showing at all now . car is right hand drive
thank you in advance

Frango100 01-11-2013 09:43 AM

Re: transmission selector lights
 
3 Attachment(s)
Welcome to the garage.
This could be a problem with the transmission shift selector assy, but also a bad ground somewhere. The ground for the shifter assy is just behind this assy on the left side, called G200. I just found this ground some days ago for an other member with different problems. Maybe good to have a look overthere and to remove/clean/install the connector on the shift assy to be sure no bad contact is there.

cheapjeep 01-11-2013 09:49 AM

Re: transmission selector lights
 
Not really familiar with the WG especially a diesel but are the rest of the dash lights also going out with the shifter? This might be a sign of a deeper electrical issue and that might explain the no drive issue. If not I can't see how the 2 issues are tied together because the electro luminescent lighting in the shifter is a known issue with the WJ but is only confined to the instrument lighting circuit. But like I said I don't know WG diesels so things could be way different . Hang in there though,we have an excellent troubleshooter on here. I'm sure Frank will see this post and chime in soon to help.

kennytheone 01-11-2013 10:19 AM

Re: transmission selector lights
 
hi thank you for your replies and yes its only the lights that are next to the shifter that go out. once theyare back on the drive is back.
will check out the ground

kennytheone 01-11-2013 12:04 PM

Re: transmission selector lights
 
well i have checked the g2oo and give it a good clean . but same issue still there. so any more help to what else it may be

Frango100 01-11-2013 03:35 PM

Re: transmission selector lights
 
If you could make a test lead which will measure the power to the shift selector assy, then you can see if the problem is power feed related. But im afraid that the problem is the shift selector assy itself. No idea if you can do anything on that assy itself. Maybe an other CRD member could tell more about that.

kennytheone 01-11-2013 05:44 PM

Re: transmission selector lights
 
i will see if i can get hold of a replacement shift selector assy and see if that fixs the problem but i only found left hand drive ones so far . will try and report what happens ty for advice

Frango100 01-11-2013 06:03 PM

Re: transmission selector lights
 
Those assys seem to be quite expensive, so you better be sure that the problem is in there.
Just found the name jeep gave to this selector: SLSA= selector lever sensor assembly. It is a microprocessor equipped module that uses 12 hall effect sensors to determine the selected gear position and to send this info to the TCM, which is mounted just on the right hand side of the assy. Did you check if there is a connector on the assy and did you remove it to see if the pins are all clean?
If you could find anybody with a DRBIII scanner, you could maybe find out what the problem is before changing any part.

kennytheone 01-12-2013 08:56 AM

Re: transmission selector lights
 
hi well cleaned all conectors. but what i have noticed is when i get into car put key in turn till just dash lights light up but not start wait about 30 second till a 1 minute then car starts and drives every time. as long as i wait its ok so seems to be some kinda delay thats involved it that helps

Frango100 01-12-2013 11:13 AM

Re: transmission selector lights
 
Seems to be a problem in the shifter assy itself. Can't you get your hands on a DRBIII scanner somewhere?

kennytheone 02-10-2013 06:18 AM

Re: transmission selector lights
 
well hi just up date well been working away so not hd time to work on car but is still the same go out to car she starts green lights are on on shifter panel switch key off and right back on no lights still no drive have notice when it happens i still have 4low an car still drives
thinking back all this started to happen after we hasd floods and i had to drive threw deep wateris there some tink underneath the car that might need checking just a thought still trying to locate a shift assembly but are few and far find lots with levers on oppersite side but none the same on ebay etc

Frango100 02-10-2013 06:31 AM

Re: transmission selector lights
 
I don t know the transmission on the CRD, but there should be a connector on it somewhere. Remove it and check for moisture in it. I would disconnect the battery before taking the connector off.


All times are GMT -5. The time now is 07:49 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community