Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   getting a load of codes (http://www.jeepgarage.org/f77/getting-a-load-of-codes-53017.html)

Zombie 01-15-2013 06:05 PM

getting a load of codes
 
Quick recap of what happened.Had 3 days of rain, then it dropped to the 20's overnight. I start the Jeep and it instantly goes to a 1400rpm idle. Get in and see the check engine light. On the way to work, I lose all gauges and overhead console display. I did the gauge test with the reset button, it went through the 111111 222222 etc. Did the key flip to get the codes and this is what I got. P0123, P1698,P1687,P1686. In order. After I did that, the gauges all work fine but I'm still getting the engine light. I've searched several forums and found everything from bad ground, clock spring or TCM. The one that said TCM had the same codes and I was wondering if this is a probable cause. Thanks folks... Oh, and I noticed the power mirror had swung full out adjustment. I'm scared:eek: its possessed

Zombie 01-16-2013 09:50 PM

Re: getting a load of codes
 
well whatever was on the fritz fritzed out completely. Now the dash lights (not the warning lights) come on about 5 sec. after the ignition is turned on, the Jeep will start but dies in about 5 seconds. Checked the C200 for moisture/corrosion, all good. tried reading the codes again and now it wont even do that.. HELLLLLLLPP!!!

robpp 01-17-2013 02:16 PM

I can't see the model year but if it wk


Battery
Ign switch
Multi func stalk

In that order.

Zombie 01-17-2013 03:56 PM

Re: getting a load of codes
 
WJ, 99 Ltd. with the 4.7, Quadradrive...Battery is new, Ign. switch SEEMS to function properly and dont know what the multi func. stalk is (the levers on the column?) but everything was operating fine then out of the blue, its done this in a matter of 2 days. The power mirror swinging out when I open the door just blows my mind lol Give me back carbs and distributors ANY DAY!
Thanks for the info, I dont have the needed test equipment so it may be making a trip to a garage...my soul died a little when I typed that:(

Zombie 01-18-2013 11:43 PM

Re: getting a load of codes
 
I think the PCM has brain damage :-(

Frango100 01-19-2013 02:47 AM

Re: getting a load of codes
 
Did power windows, power locks stop working as well? This seems to be a problem with the PCI data bus. Via this bus also the signal from the SKIM has to go to the PCM. If the PCM doesn't receive this signal, it will stop the engine after some seconds of operating. This can be a hard one to find, could be the PCM, but also any of the other components connected to this bus. There is a connector under the steering wheel, where all PCI bus wires join together, this connector has a shorting cap, which makes the connection. From here you could start trouble shooting, by connecting one by one until the PCI power goes back to normal. Normal bus power seems to be around 2.5 V, when it is significantly higher (4-7 V), there is a component which is faulty. This voltage you can measure at the data connector point 2 (this is the connector where you can connect a scanner)
Oh, and the multi function stalk is indeed the left or right switch levers on the steering column.

Zombie 01-20-2013 12:22 AM

Re: getting a load of codes
 
Thanks, that helps a TON! at least I have an idea where to start now.

Frango100 01-20-2013 07:43 AM

Re: getting a load of codes
 
3 Attachment(s)
Attached 3 pages from the wiring schematics. Here you can see all the components connected to the PCI bus. When you remove the shorting cap from the Diagnostic Junction Port (under the steering wheel), then still the PCM, TCM and SKIM are connected together. If the engine will start then (and keeps running:D), you know that the problem is not in one of these components. Then just connect one at a time a component to point 1 on the diagnostic junction port, until the problem is there. It could be that not a component is causing the problem, but just a shaved wire, but then the bus voltage should be very low or even 0.

Frango100 01-20-2013 07:48 AM

Re: getting a load of codes
 
1 Attachment(s)
And here the location of the diagnostic junction port. It seems to be hidden a bit in a wire bundle.
Oh, and about the power mirror, is it the passengers side mirror which swung out completely? Each mirror is controlled from its onside door module and also the memory function is inside each door module, but also the PCI bus is used for communication between the 2 door modules.

Zombie 01-21-2013 05:45 PM

Re: getting a load of codes
 
You sir are a saint! So now for the scary part. Get home today, ready to do some voltage tests and some wire chasing. Open the door...yup, dome lights work, all power accs. work. So I thought ,"what the hell", hit the key, she fires right up, NO check engine light and its sitting there purring like a kitten. Its been in the garage for 5 days out of the weather. I'm "HOPING" it was just a moisture issue. Like I said in my 1st post, it had rained hard for 3 days and dropped into the 20's the morning all of this started. Funny thing is, I looked at the C200 and the TCM plugs and niether showed any signs of corrosion or moisture. I'll try a few short trips with it before I trust it for my daily driver again, but I do want to sincerely thank you for your time and help.I can honestly say I have never received this quality of information on ANY forum on ANY subject. Oh, and I have this thread saved to my favorites JUST IN CASE it didnt fix itself (which in my history with cars has never worked for long). This is why I like my race car, it has 4 wires to the engine and 2 run the water pump lol. Thanks again, Andy

Zombie 01-21-2013 05:50 PM

Re: getting a load of codes
 
http://i782.photobucket.com/albums/y...0904112242.jpg
See, no wires ;-)

Frango100 01-21-2013 07:07 PM

Re: getting a load of codes
 
Youre welcome, its my pleasure to dig into problems and try to help others out.
Funny though that the jeep repaired itself, lets wait and see how it behaves the next weeks.
By the way, did you build your racecar yourself? That must be a nice hobby!!!:thumbsup:


All times are GMT -5. The time now is 12:14 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community