Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Overland does not start. Or misfiring when started (http://www.jeepgarage.org/f107/overland-does-not-start-or-misfiring-when-started-54061.html)

Trevorj 02-01-2013 03:28 PM

Overland does not start. Or misfiring when started
 
When I start the vehicle the engin cracks but it does not start. The starter keeps on turning till you switch the vehicle off. If you start it again it will start, or it will start and then revs will drop below 500 and it sound if its only running on 4 cylinders. You try to rev the engine up but it will stall. Had in at the dealer but they could not find any error codes. It happen to them as well. They unpluged all electrical plugs and cleaned them out but they dont know what the problem is.
This happens is any time, hot or cold.
Had another issue as well. Within 6 hours the battery ran totally flat. It happen twice in 6 day time. Just replaced the battery. How can a battery run so flat within 6 hour. Had it load tested it was fine.

Hope there is some advise out there

77Cherokee 02-01-2013 06:46 PM

Re: Overland does not start. Or misfiring when started
 
The battery is probably draining due to a short somewhere, which may also be the cause of your no-start problem. I would think your dealer could find something like that.

Trevorj 02-02-2013 12:18 AM

Re: Overland does not start. Or misfiring when started
 
We did an amp test and it was very low. Lets see if the new battery helped


All times are GMT -5. The time now is 12:19 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community