Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Oil Light On (http://www.jeepgarage.org/f181/oil-light-on-54249.html)

Madanio24 02-04-2013 05:41 PM

Oil Light On
 
Hey guys the other day my oil light came on (20 degrees outside) i checked my level and it was right on the line of safe. So i figured because it was so cold and on the border that i would top it off tomorrow. That same night I went to start it again after the engine was warm and there was no oil light. The next day i decided to fill it with oil. After that I havent had any problems with the light for a few days. Now when i started the jeep the oil light came on again. The engine is running fine and has plenty of oil. Then when i turned the engine off and started it again the light went off. Im thinking oil sensor?

2005JGC 02-04-2013 09:51 PM

Re: Oil Light On
 
Likely just the oil pressure sender... decently common. located just above the oil filter.

Madanio24 02-04-2013 10:08 PM

Quote:

Originally Posted by 2005JGC (Post 754413)
Likely just the oil pressure sender... decently common. located just above the oil filter.

Thats what i thought. Thanks wilk try to fix this weekend. Will i have to drain the oil?

TMJeep 02-11-2013 03:11 PM

Re: Oil Light On
 
It is actually called an oil pressure switch. I had a hard time finding because I was searching sensor.

No you will not have to drain the oil. It will leak just a little though.

It is a pain in the rear to change because of the length of where the socket connection is on the unit itself and being able to reach it. I tried an open ended wrench and then I was going to use a deep socket but the same size deep socket is too big because of the rounded edges of the unit.. The only way I was able to get it off was to use a pair of channel locks.

TMJeep 02-11-2013 03:14 PM

Re: Oil Light On
 
One question for you though. Is your engine leaking oil right above and left of the oil pressure switch?

Mine, my parents and sisters are also. That is what caused my switch to go bad because it was leaking and the wire connection was full of oil.

2005JGC 02-11-2013 05:30 PM

No that oil is coming from rfe sender itself, another indication of failure, very common!

Sent from my SCH-I500

TMJeep 02-12-2013 05:46 AM

Re: Oil Light On
 
Quote:

Originally Posted by 2005JGC (Post 758173)
No that oil is coming from rfe sender itself, another indication of failure, very common!

Sent from my SCH-I500

What is an rfe sender? Is it very easy to get to to replace or fix?

2005JGC 02-12-2013 03:04 PM

Quote:

Originally Posted by TMJeep (Post 758496)
What is an rfe sender? Is it very easy to get to to replace or fix?

Rfe = the, but in broken swype language

Sent from my SCH-I500

TMJeep 02-12-2013 05:47 PM

Re: Oil Light On
 
Quote:

Originally Posted by 2005JGC (Post 758714)
Rfe = the, but in broken swype language

Sent from my SCH-I500


Oh no wonder I had a hard time trying to thing what kind of sender that was.:lol:

Madanio24 02-13-2013 03:18 PM

Re: Oil Light On
 
2 weeks and no oil light. I think theres something to do with frigid cold and th elight coming on.

hummer recovery team 02-14-2013 03:05 PM

My parents jeep was doing the same thing I unplugged the connector to the switch and cleaned it and plugged it back in a d no more problems. Weird issue.


All times are GMT -5. The time now is 07:39 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community