Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Low engine speed on Tachometer (http://www.jeepgarage.org/f181/low-engine-speed-on-tachometer-54338.html)

Bjorn 02-06-2013 04:12 PM

Low engine speed on Tachometer
 
Hi guys

I just joined the forum after I found solutions here concerning troubles I had
with error code P1499. I realized through that there are lot of guys out there which share my love for jeep grand cherokee and have experienced same problems I have had and are very helpful and willing to share their knowledge.

I live in Iceland and have a Grand Cherokee overland 4.7l, 2004. I imported this car from USA in 2007, then it had 60.000 miles. I love this car and it has been running relatively smoothly expect for I had to replace the starter and a water pump besdies normal maintainance. Now it has 114.000 miles and I had to change head gaskets and timegear. It was done in private garage by mechanic. It did cost me about the half of the retailprice.
When I got the jeep back I noticed that the Tachometer was showing just above 300 rpm but before the repair it was rock steady on 600 rpm. Inspite of this low reading the engine is running smoothly and seems to be running higher speed than the Tachometer indicates and the consumption seems to have increased. Does anybody know what is going on here ??

All the best,

Björn


All times are GMT -5. The time now is 01:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community