Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Auto Climate Control Display Problems (http://www.jeepgarage.org/f107/auto-climate-control-display-problems-54411.html)

wkbrdpro 02-07-2013 04:01 PM

Auto Climate Control Display Problems
 
1 Attachment(s)
Hey I just installed my auto climate controls and all of the display controls appear (see attached file).

I have no idea why it is doing this or what to do about it. You guys have any ideas?

RageOfFury 02-07-2013 08:26 PM

Re: Auto Climate Control Display Problems
 
Disconnect the battery, wait 5-10 minutes, re-connect. See if that solves the issue.

wkbrdpro 02-07-2013 10:14 PM

Re: Auto Climate Control Display Problems
 
Just went under the seat and disconnected the negative wire and still get the full display lit up.

Do I need to disconnect the positive wire too? I figured disconnecting the negative one would be enough.

wkbrdpro 02-07-2013 10:15 PM

Re: Auto Climate Control Display Problems
 
I just realized you said 5-10 min... I only waited 30 seconds (I read 5-10 seconds).

I will try again.

I am guessing this resets the wiring?

RageOfFury 02-07-2013 10:22 PM

Re: Auto Climate Control Display Problems
 
Disconnecting the battery should reset things. I would also double check the harness that plugs into the auto controls. Make sure it's plugged in properly and no bent pins.

RageOfFury 02-07-2013 10:24 PM

Re: Auto Climate Control Display Problems
 
1 Attachment(s)
Ermmm wait a minute. The display on yours doesn't look like mine at all! I have no rear and the Auto is located elsewhere. Did you perhaps get the one from a Durango by chance?

Edit: here's the picture of mine

wkbrdpro 02-07-2013 11:40 PM

Re: Auto Climate Control Display Problems
 
Hmm yours does look different than mine.

The part number is 55111916AP and that is what I have seen in all the swaps I have searched.

AAAA 02-08-2013 08:20 AM

Re: Auto Climate Control Display Problems
 
Different than mine too!

WickedXJ 02-08-2013 09:44 AM

Re: Auto Climate Control Display Problems
 
Whoa guys, lets not jump to conclusions, looks where my AUTO is :confused::confused::confused:
http://i608.photobucket.com/albums/t...psa9f18ccc.jpg

But I couldn't get FRONT or REAR to show on the display.....

wkbrdpro 02-08-2013 10:05 AM

Re: Auto Climate Control Display Problems
 
Yeah, but the fan speed reading is different (arched vs straight).

I ordered the 55111916AP but I think I was sent 55111916AQ

I disconnected the battery for 15 minutes and nothing changed.

I'm guessing the AQ is not going to work in my Grand Cherokee?

RageOfFury 02-08-2013 10:28 AM

Re: Auto Climate Control Display Problems
 
Hmmmm...where did you buy it from?

I'm thinking that the 55111916AQ is for the Durango. Have you checked the harness that plugs into it?

WickedXJ 02-08-2013 10:29 AM

Re: Auto Climate Control Display Problems
 
Quote:

Originally Posted by wkbrdpro (Post 756302)
Yeah, but the fan speed reading is different (arched vs straight).

I ordered the 55111916AP but I think I was sent 55111916AQ

I disconnected the battery for 15 minutes and nothing changed.

I'm guessing the AQ is not going to work in my Grand Cherokee?

Mine is arched, same as yours. Did you buy from Just for Jeeps? They seemed pretty good, I would give them a call.

The AQ would have heated seats, and would work no problem in your GC, I bought the heated and ventilated, and I have neither and it works no problem. Yours looks like the AP, but like some others have said, not sure where the Front/Rear is coming from on your display.


All times are GMT -5. The time now is 09:31 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community