Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   do i have an engine problem? (http://www.jeepgarage.org/f107/do-i-have-an-engine-problem-54691.html)

charcoalblack 02-12-2013 09:47 PM

do i have an engine problem?
 
hello,

not sure if it's my imagination or if I do have an issue. I have a 2011 V8 model. Owned it closed to 2 years come April. When the engine goes into ECO mode, if I want to accelate, sometimes the power won't come immediately when I hit the gas and will take a little bit longer than immediately (happens when i'm driving around 50mph or higher). It doesn't happen all the time but on some occasions. Not sure if this is normal or not.

Sobrut911 02-13-2013 07:30 AM

Re: do i have an engine problem?
 
Same with my 2012 v8. I think it's normal. If you stomp on the accelerator it'll kick down to lower gear and you'll get better acceleration.

padgett 02-13-2013 04:26 PM

Re: do i have an engine problem?
 
Slapping the gearstick is faster than stomping if you want a downshift.

Ricko 02-13-2013 05:32 PM

Re: do i have an engine problem?
 
i know this isn't on topic with OP but at high speeds 60-65mph how is everyone engine breaking.. I drive to school everyday and I notice if i let off the gas the truck starts to slow down pretty fast with out me hitting the brake anyone else feel this?

padgett 02-13-2013 06:10 PM

Re: do i have an engine problem?
 
With the aerodymanics of a brick wall, at speed you do not need to do much, just reduce power and hope the DFCO is fast.

ColdCase 02-13-2013 07:51 PM

Re: do i have an engine problem?
 
Do you have the adaptive cruise/cross path detection.. etc package? Not sure if all WK2s or just the ones with this package but a bit of brake is applied when you suddenly lift the throttle. Its a safety feature that gives a head start braking on panic stops.

charcoalblack 02-13-2013 08:15 PM

Re: do i have an engine problem?
 
Quote:

Originally Posted by ColdCase (Post 759613)
Do you have the adaptive cruise/cross path detection.. etc package? Not sure if all WK2s or just the ones with this package but a bit of brake is applied when you suddenly lift the throttle. Its a safety feature that gives a head start braking on panic stops.

no, i don't have that. So i'm not sure if it's my imagination or fuel pump or what. it doesn't appear to happen all the time so i'm not sure.

wjs81866 02-19-2013 03:42 PM

Re: do i have an engine problem?
 
Both of mine do this; I will say that mine is better than my wife's. I have a Volant air intake and a catch can. While I don't think these are the fix all it's apparent that it's helped. Probably the catch can more than anything. Sounds like some of the new tuners that are out will help but none seem to deal with the transmission kick-down which is what you are really talking about. Mine is sometimes very sensitive and other times it's like WTF?

charcoalblack 03-02-2013 01:39 AM

Re: do i have an engine problem?
 
Quote:

Originally Posted by wjs81866 (Post 763144)
Both of mine do this; I will say that mine is better than my wife's. I have a Volant air intake and a catch can. While I don't think these are the fix all it's apparent that it's helped. Probably the catch can more than anything. Sounds like some of the new tuners that are out will help but none seem to deal with the transmission kick-down which is what you are really talking about. Mine is sometimes very sensitive and other times it's like WTF?

so in your opinion, you feel this is "normal" operation for the V8 engine?

thanks


All times are GMT -5. The time now is 06:28 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community