Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Transmission Shudder (http://www.jeepgarage.org/f203/transmission-shudder-54935.html)

bestes89 02-17-2013 08:37 PM

Transmission Shudder
 
I have a 2002 GC Overland with the 4.7V8 and am experiencing a problem.

When driving at highway speeds (55-70 MPH) The transmission shifts in and out of OD. When the downshift occurs there is a shudder, harder at higher speeds and softer at the lower speeds. The shift will always occur when the RPMS increase ~200-400. The transmission acts like it is trying to search for a gear but is at a halfway speed between OD and the lower gear.

Any ideas on what the main cause may be?

Thumper828 02-17-2013 10:39 PM

Re: Transmission Shudder
 
You could test you Throttle Posistion sensor, If you have a ohm meter.

Frango100 02-18-2013 05:02 AM

Re: Transmission Shudder
 
Its most probably the torque converter clutch unlocking/locking what you see.
This is often caused by a TPS sensor which is on its way out. Like If you have a scanner which shows live data, you can see the TPS in %, just look if the indication is steady or fluctuating. I have never tried to measure it with an ohm meter, but could be good as well.

bestes89 02-20-2013 05:45 PM

Re: Transmission Shudder
 
Well, just changed out the TPS and the idle has leveled out to ~650-700 RPM, the RPM rev at start up also went away as well. Going to test if the shudder is still there when I drive home from work.

fin1211 02-20-2013 06:27 PM

Quote:

Originally Posted by bestes89 (Post 764091)
Well, just changed out the TPS and the idle has leveled out to ~650-700 RPM, the RPM rev at start up also went away as well. Going to test if the shudder is still there when I drive home from work.

Sounds like you figured it out, job well done.

bestes89 02-20-2013 08:04 PM

Re: Transmission Shudder
 
Testing when well, shudder is almost completely gone. Only a very slight vibration occurred upon downshifting from OD, that could be due to the length of time that it was driven before changing TPS (occurred before I obtained vehicle).

Thanks for the input guys!


All times are GMT -5. The time now is 07:35 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community