Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   washer fluid pump? (http://www.jeepgarage.org/f181/washer-fluid-pump-55154.html)

No-Good-Humor 02-21-2013 11:03 AM

washer fluid pump?
 
so just got my 05 GC and got it home and noticed went to use my wipers no fluid came out of front or back. am thinking its the pump because i don't hear it. but i was told there was two pumps one for front and one for back and neither should will go at the same time but i think this is bad advise not sure... i kno its a 05 had it for a week on Saturday so am OK with it having a couple problems for me to fix. but any advise will help thanks and i can say enjoying the jeep already.

dr.lee.baugh 02-21-2013 02:07 PM

Re: washer fluid pump?
 
There is just one pump. The direction that the impeller on the pump rotates determines whether fluid is sent to the back or the front.

The first thing I would check is make sure someone didn't leave summer washer fluid in that has now froze up.

If that's not the case, it could be the pump or perhaps the switch. I would think if the wipers are wiping when you try to clean the windshield the switch is fine and would likely swap out the pump. It's not an expensive or difficult thing to replace.


All times are GMT -5. The time now is 08:48 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community