Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Blend Door or Actuator Motor? (http://www.jeepgarage.org/f181/blend-door-or-actuator-motor-55611.html)

lermfl20 02-28-2013 08:56 PM

Blend Door or Actuator Motor?
 
My Jeep GC Laredo, 2010, worked great and then out of the blue, I have no cold air in the cabin, just heat. Fans work, A.C. compressor works fine and pipe is ice cold coming out of the compressor. My mechanic thinks the door broke in the A.C. housing. I have hot air blowing out of all vents regardless whether I have the heat or the a.c. on. No clicking noise and no smell. My battery died the other day and when I had it tested today it said it failed but had a 100% charge. I plan on replacing battery but wonder if the battery dying may have messed up something in the computer that calibrates the actuator when you turn on the car. It seems premature for a 2010 to have a broken blend door. Could it be something else? I have ordered a core regulator from heattreater. Is it possible to reset the computer. I disconnect the battery for 30 seconds. Didn't work.
img.imageResizerActiveClass{cursor:nw-resize !important;outline:1px dashed black !important;} img.imageResizerChangedClass{z-index:300 !important;max-width:none !important;max-height:none !important;} img.imageResizerBoxClass{margin:auto; z-index:99999 !important; position:fixed; top:0; left:0; right:0; bottom:0; border:1px solid white; outline:1px solid black;}

HemiDawg 03-04-2013 10:25 AM

Re: Blend Door or Actuator Motor?
 
Just had my door replaced on my 2010 - said teeth had broken off of the gear which opens the door (think that was the diagnosis). Mine would open eventually but I would get a god-awful clicking noise usually when using the remote start and right after inserting the key.

lermfl20 03-05-2013 07:11 AM

Re: Blend Door or Actuator Motor?
 
Nice Jeep. Mine doesn't click, yet... It seems to be sluggish. I watched the door axle turn as I adjusted the heat. It seems to have some movement but not the full range. I had no a.c., now I have a little and I didn't really do anything. Heat is not a problem. Fan is working fine.
img.imageResizerActiveClass{cursor:nw-resize !important;outline:1px dashed black !important;} img.imageResizerChangedClass{z-index:300 !important;max-width:none !important;max-height:none !important;} img.imageResizerBoxClass{margin:auto; z-index:99999 !important; position:fixed; top:0; left:0; right:0; bottom:0; border:1px solid white; outline:1px solid black;}


All times are GMT -5. The time now is 01:59 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community