Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Video/Navigation/Alarms (http://www.jeepgarage.org/f165/)
-   -   Amp issues (http://www.jeepgarage.org/f165/amp-issues-56066.html)

wk2limited5.7 03-07-2013 09:45 PM

Amp issues
 
My stereos been cutting in and out! Took it to the dealer...tech says the amp is muting then unmuting...only one speaker playing now! Apparently amp is on national backorder. Anyone else had any issues with 2012 SRT?! Paid extra for upgraded stereo

mrajprc 05-06-2013 03:16 PM

Re: Amp issues
 
I have had the same issues with my 2012 model. It all begin during long road trips (obviously with the music cranked). I would find my sound unit go completely mute and would stay that way for a very long time. Although the nav screen still worked (along with the volume buttons as I could see myself adjusting the sound up and down), still no sound would come out. I tried cutting the car off and then turning it back on but to no avail, still nothing changed.

If I let the car sit for a hour or so then the unit would resume as normal. I have also had instances where the volume button did not work also.

I have since taken my unit to the dealership and had the unit replaced with a new one (I took video clips of the issues as they were happening so the guys at the dealership wouldnt just pass it off as a glitch).

Now that I have the "new" nav, I do not experience sound problems however I do still experience other problems like the reverse screen (back up camera) displaying when NOT in reverse, the screen getting stuck in a certain mode, as well as the actual navigation component messing up.

Not sure if this helps but you are definitely not alone on this.

XLR8R 05-07-2013 11:17 PM

classic sign that the amp is going into thermal protection from getting overly hot to keep from frying (no audio but head unit works)

Sounds like its underpowered for the load its pushing, or not dissipating heat efficiently or fast enough...or just plain bad quality


All times are GMT -5. The time now is 06:07 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community