Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   05 4.7 WK stalling issue after battery change (http://www.jeepgarage.org/f181/05-4-7-wk-stalling-issue-after-battery-change-56270.html)

Kevman 03-11-2013 09:56 AM

05 4.7 WK stalling issue after battery change
 
Hi guys, a week ago i had to remove the battery & have it charged up cause i drained it. now after re-installing it ive got one hell of a stalling issue. it doesnt stall when idling, but it cuts out when slowing to a stop(im talking city driving, stop-start speeds here).

now i havent had this issue before i changed out the battery so im wondering if ive possibly reset something in the PCM. google threw up a few(non jeep specific) threads where an "idle relearn procedure" + bad/gunked-up throttle body is the cause.

can this be the cause on my vehicle as well? do you guys know if the WK PCM's have an "idle relearn procedure" ? :confused:

vehicle has 97K & hasnt had a service for the last 20K km:eek: .

thanks in advance guys for any help!

dr.lee.baugh 03-11-2013 10:04 AM

Re: 05 4.7 WK stalling issue after battery change
 
Have the battery load tested or swap it out with a known good one.

It's quite possible that by draining the battery it has been damaged and not able to hold a charge properly.

You should not have to perform any sort of calibration after cutting power to the Jeep. Many learned control settings will need to be re-learned (transmission adaptives, etc), but none of these should result in stalling issues.

Kevman 03-11-2013 10:17 AM

Re: 05 4.7 WK stalling issue after battery change
 
Quote:

Originally Posted by dr.lee.baugh (Post 777991)
Have the battery load tested or swap it out with a known good one.

It's quite possible that by draining the battery it has been damaged and not able to hold a charge properly.

You should not have to perform any sort of calibration after cutting power to the Jeep. Many learned control settings will need to be re-learned (transmission adaptives, etc), but none of these should result in stalling issues.

im not very familiar with transmission adaptives. While relearning the transmission adaptives, is it possible that the tranny is simulating/recreating an "idle undershoot" (is that the correct term??) situ where the T/C unloads & stalls the engine - as when the ATF level is low?

dr.lee.baugh 03-11-2013 11:57 AM

Re: 05 4.7 WK stalling issue after battery change
 
Shouldn't.

The default settings for the transmission work perfectly fine - they just aren't the most efficient and/or comfortable.

As the transmission controller learns more about your driving style, it can soften or firm up shifts and/or change shift-points slightly to make it run a little smoother for your specific driving style.

Kevman 03-13-2013 02:25 AM

Re: 05 4.7 WK stalling issue after battery change
 
ok, ive read up alot about this stalling topic.....

lets see if i can list out the possible problems
  • Bad Battery (dont believe so since it cranks right up after a stall)
  • Gunked-Up TB (applicable only if PCM utilises an IDLE relearn procedure?)
  • low ATF in transmission (mine is on the high side when hot, does high ATF also cause problems:confused:?)
  • Faulty Tq/C (i really hope not!:()
  • Faulty Sensors
    • TPS
    • Crank position sensor(noted to be installed under tension in the 5.7)
    • Cam Position sensor
  • Bad EGR
  • Bad IAC
  • Ignition wiring harness(noted in 5.7,is it applicable for the 05 4.7:confused:?)
  • Ignition coil
ive got a OBDLINK SX on the way... im gonna start by eliminating issues from the top of the list & use the scanner to ID which sensors need changing (if any) ...

any further info from you guys is also most welcome.

Kevman 03-20-2013 10:36 AM

Re: 05 4.7 WK stalling issue after battery change
 
well, i did the following,

cleaned TB,
replaced TPS+IACV+PCV.

& now its MUCH better... still experianced a couple of stalls since then, but nowhere near as bad as it was.

im beggining to think the 4.7 stall problem is a caused by a combination of issues.

will try the EGR & Trans fluid next. anyone got any tips on the EGR removal? :thumbsup:

hummer recovery team 03-22-2013 08:48 AM

Good to hear, I would also change the plugs to the stock champion 434

Kevman 03-22-2013 09:31 AM

Re: 05 4.7 WK stalling issue after battery change
 
Quote:

Originally Posted by hummer recovery team (Post 785445)
Good to hear, I would also change the plugs to the stock champion 434

you mean 439 right?

hummer recovery team 03-22-2013 10:07 AM

I think so

Kevman 10-11-2013 09:52 PM

Re: 05 4.7 WK stalling issue after battery change
 
well, im gonna fill a gap in this old topic , just in case some one comes across a similar situ.
long story short, i can only definitively say the following.

the extremely bad idle stalls were solved by:
changing out the TPS/IACV/PCV + a TB clean.

this changed the stalling from "bloody frequent" to "infrequent & driveable"

still experiance the idle suddenly wobbling from time to time. replaced the plugs to champion 439's... no dice.

the infrequent idle stalls were solved by:
changing out the EGR + tranny fluid/both tranny filters.

As ive fixed my problem, i cannot pinpoint which was the exact root cause of the problem. at no point did i actively reset the PCM, but it may have happened. (i say this cause im currently looking for the applicable PCM reset for my engine).

best of luck on T/S to anybody with a similar problem!

PS: thanks to all who provided info & the guidance from info on the numerous other threads on the forum!!


All times are GMT -5. The time now is 05:20 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community