Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Crappy idle (http://www.jeepgarage.org/f181/crappy-idle-56314.html)

Madanio24 03-11-2013 10:34 PM

Crappy idle
 
Trying to diagnose the crappy idle I have had ever since I got the jeep. I noticed something interesting the other day the ac compressor engages even when the system is off. Is this supposed to happen?

2005JGC 03-12-2013 01:04 AM

Re: Crappy idle
 
If your defrost is on, yes. It uses the evaperator to dry the air out so it does cycle the compressor.

If you have a 4.7l I am sure there may be some thing that might smooth it out, I have never been able to isolate it and it seems to happen on A LOT of 4.7l's in WK's. The fact that there are no codes doesnt mean everything but it is a pretty good indication that at least according to the software everything is within parameters. I noted on a couple I have looked at for myself (my own, and one I fixed a misfire on) that they dont count misfire when idling rough.

I have heard it suggested that with a tuner, raising the idle speed up 50 rpms or so helps to smooth it out.

Madanio24 03-12-2013 04:46 AM

Re: Crappy idle
 
Great to know. Yes I had front defroster on. I have 3.7 with hypertech I wonder if I can adjust idle on that. Randomly the car shakes while at idle, exhaust shakes also. But when I start moving it drive like a dream.

Benzie002 04-08-2013 10:49 AM

Re: Crappy idle
 
I had the same problem. I cleaned the IAC motor, it was really dirty and I replaced the TPS sensor only because it broke apart when I tried to take the connector off.

ALPINEST4RS 04-08-2013 11:19 AM

Re: Crappy idle
 
there is a ecm update for the 3.7L for a rough idle/no cel. I don't have any info on it, but my buddy updated mine and it fixed it.

Madanio24 04-08-2013 03:41 PM

Re: Crappy idle
 
How old is this update? mine was updated about a year ago.

ALPINEST4RS 04-09-2013 07:36 AM

Re: Crappy idle
 
ah yeah then you already got it. had to of. I had the same rough idle as you too. Do you have a aftermarket intake? When I installed mine it seemed to take car of most of it, but the ecm update helped finish it off.

Madanio24 04-09-2013 11:42 AM

Re: Crappy idle
 
Yes K&N intake

BASSO'MATIC 04-09-2013 11:52 AM

Re: Crappy idle
 
Maybe this will help......maybe not. I have the 4.7 and dealt with a rough idle in the past. It got so bad that I would stall out at stop signs, lights, etc. I changed all of the valves and sensors related to this issue and changed the spark plugs as well. None of these things helped at all. I later removed the throttle body and cleaned it thoroughly.....wouldn't you know...it solved the issue. Now I make sure to clean it every few months or so. Might work for you...might not. Won't cost you anything to try at least.

Madanio24 04-09-2013 03:03 PM

Re: Crappy idle
 
Thanks for the input already cleaned the throttle body. changed idle sensor and almost every sensor in the car! I have another thread "surging pulsing while driving" that explains everything

BASSO'MATIC 04-09-2013 06:40 PM

There is another post somewhere I remember reading a while ago that pertains to the issue. The guy says it has to do with the teeth of some electrical connection being bent and not making solid contact somewhere. Don't remember which connection though. Seemed like he knew what he was talking about. I'm sure a search will reveal his post. Good luck.

Madanio24 04-09-2013 10:33 PM

Re: Crappy idle
 
I don't know if this matters but when I accelerate there is a high pitched hissing noise wheni give it gas. Can hear when windows are down.


All times are GMT -5. The time now is 08:11 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community