Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Front headlamp not working -- any help?? (http://www.jeepgarage.org/f181/front-headlamp-not-working-any-help-56359.html)

BravoKilo 03-12-2013 06:02 PM

Front headlamp not working -- any help??
 
Had my front left headlamp go dead on me a week ago (2008 WK, v6). Purchased new bulbs hoping it would solve the issue, but to no avail.

Headlamps are a HID conversion and had been working great for over a year. Just noticed that one had stopped working.

Working on picking up a volt-meter to start testing connections, but was curious if anybody had any other suggestions?

Tried finding the appropriate fuses/relays at Jeep Grand Cherokee WK - Fuses, but unless I'm blind, I'm not seeing anything for low beams.

Any help??

2005JGC 03-13-2013 01:00 AM

Re: Front headlamp not working -- any help??
 
Make sure your powers and grounds are good. Realistically, you didnt say where you got the kit from so I would lean towards a cheaper establishment, 1 year for crappy ballasts is not uncommon.

BravoKilo 03-13-2013 01:14 AM

Re: Front headlamp not working -- any help??
 
Hoping for nicer weather this weekend to get out and start checking connections and grounds. Any easy way to test if a ballast is still good or not? Simple as testing continuity from one end to the other or any specifics I should be reading on a multimeter?

I have one of the Xenon Depot kits if that matters.

Thanks for the help

2005JGC 03-14-2013 01:05 AM

Re: Front headlamp not working -- any help??
 
xenon depot are much higher quality, if you have questions with their product contact them on here via pm.

Are you using a relay harness? I have had an issue with one harness, no issues since but it actually melted the pins in the connector at the relay... The best way to test a balast is honestly with a known good. Like when one of yours worked, swapping the known good to the non working side. Contact xenon depot and see what they say, I havent dealt with them but I have only heard good things of their customer service!

BravoKilo 03-14-2013 10:19 PM

Re: Front headlamp not working -- any help??
 
Was eventually thinking I might and try to contact them, but the only issue is that I bought the kit from a board member (almost exactly 2 years ago), and not direct. It was never installed by the previous owner, but still leaves me without original paperwork, and last I checked (actually PM'ed them before I purchased the kit), warranty is only good for original owner.

Figure I'll cross my fingers and still give it a shot...


All times are GMT -5. The time now is 07:29 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community