Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   2011 GC WK2 CRD Transmission Problem (http://www.jeepgarage.org/f107/2011-gc-wk2-crd-transmission-problem-56980.html)

Big Red 03-22-2013 07:06 PM

2011 GC WK2 CRD Transmission Problem
 
I had an unnerving experience last week when my WK2 transmission dropped to neutral while joining a freeway. I was driving reasonable quickly around the 270degree entry loop when, as I was about to enter the freeway, the car lost all drive. I tried to shift to neutral and back to drive and then tried the manual shift up and down but no joy. There were no warning lights. I rolled into the breakdown lane and did a full reset by stopping the engine and locking the car.
I then started the car again and all was OK.

I thought the problem may have been caused by the Transmission fluid level being low and the higher than normal cornering speed had starved the pump however the fluid level is OK .


The dealer couldn't find any problems. Has anyone else experienced this problem?

AussieJeep 03-23-2013 03:31 AM

Re: 2011 GC WK2 CRD Transmission Problem
 
I must say its a first I think, some odd things have been reported on this site but I have not heard of the problem you faced, lets hope its a one off. All the best

Big Red 04-27-2013 09:05 PM

Re: 2011 GC WK2 CRD Transmission Problem
 
I experienced the problem 3 more times over the last month. Each time I was driving on a freeway at around 70km/h and accelerated reasonably hard. Rather than kicking down the transmission dropped into neutral- not a great experience on a freeway. On with the hazards and rolled towards the breakdown lane. When I go down to around 30km/h the transmission came good. No error messages. I can't seem to be able to reproduce the problem. I just have to be careful about when I accelerate hard. I haven't been to dealer since these last 3 occurrences as I don't think there is much point if I can't reproduce the problem.
Any suggestions would be appreciated.

JohnS 04-28-2013 12:32 PM

Re: 2011 GC WK2 CRD Transmission Problem
 
I had a similar problem. Here's a link to my post: Transmission won't engage :-(

According to the tech at the dealership, the tranny sensed the fluid flow was restricted by the dislodged filter and the computer shut my tranny down to prevent damage. Sounds similar to your issue. If your dealership hasn't already done so, they should check to see if the transmission fluid filter is installed correctly. If it is, the problem could possibly be restricted fluid flow/low fluid pressure, or even a faulty sensor.


All times are GMT -5. The time now is 10:23 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community