Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Suspension/Brakes/Wheels/Tires (http://www.jeepgarage.org/f185/)
-   -   My Tire Pressure Sensors keep breaking (http://www.jeepgarage.org/f185/my-tire-pressure-sensors-keep-breaking-56985.html)

stashgto 03-22-2013 08:43 PM

My Tire Pressure Sensors keep breaking
 
Hi folks, I've got a bit of a dilemma my tps keep breaking. They break right in the middle of the threads where the cap screws down. It was on the drivers side both times different wheel so it's not hitting curbs , or anything like that. Has anyone had this problem, and is there a better brand than original that doesn't do this?

roddaz 03-23-2013 07:23 AM

Re: My Tire Pressure Sensors keep breaking
 
I have a similar problem on my 2007 WK in the UK.
The valve stem snapped when I was washing the wheels, Using Meguiars wheel brush, right at the end of the threads.
Apparently its a corrosion issue -steel dustcaps and alloy valve stems,dissimilar metals salt on winter roads.
I got a new set of 4 from Ebay just waiting to get it into tyre shop to get them swapped over!!

stashgto 03-23-2013 07:51 AM

Re: My Tire Pressure Sensors keep breaking
 
HMMMMM, The difference in the expansion rate, and corrosion with the disimilar metals gotcha. Maybe just stick with the ugly plastic caps this time?


All times are GMT -5. The time now is 11:32 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community