Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   2005 grand cherokee 4.7 rough idle in warm/hot weather. (http://www.jeepgarage.org/f181/2005-grand-cherokee-4-7-rough-idle-in-warm-hot-weather-57478.html)

waldnerstev 03-30-2013 03:48 PM

2005 grand cherokee 4.7 rough idle in warm/hot weather.
 
i have a 2005 grand Cherokee jeep with a 4.7 v8 and 116k miles on it. bought it up in Alaska, currently live in south Dakota, and it hasn't seen any "hot" weather 75+ since Ive owned it...but 4 days ago, i drove down here to Oklahoma city, and on the way down i noticed on and off when i came to a stop it started shaking...then randomly stopped again. this has been going on all week now, but today(78F+), when i start it up, it runs smooth, then after a 5 to 10 seconds, it slowly goes into a shake. when it shakes it feels like a small 4 cylinder diesel.
I just changed all the spark plugs, didnt make a difference. And another thing, when it shakes, i can unplug each coil and on every one you do notice the RPM change and the shaking doesn't stop, so i dont think its a dead cylinder/plug/coil/injector. and even it would be a dead cylinder...it shakes a LOT worse then it would if I just had a coil misfiring.

any ideas?

hummer recovery team 03-30-2013 06:15 PM

Mine has done this for awhile, egr valve mostly cured my problems along with a tps sensor, does the idle go up when ac is turned on?

waldnerstev 03-31-2013 03:05 PM

Re: 2005 grand cherokee 4.7 rough idle in warm/hot weather.
 
The idle was rock solid at 600rpm...
it was the electric AC condenser fan, it was caked full of mud which threw it off balance, took it to the car wash, took a water hose to it, cleaned it off, and no more vibrating...

SvenskaJeepGuy 04-01-2013 11:55 AM

Re: 2005 grand cherokee 4.7 rough idle in warm/hot weather.
 
Quote:

Originally Posted by waldnerstev (Post 792756)
The idle was rock solid at 600rpm...
it was the electric AC condenser fan, it was caked full of mud which threw it off balance, took it to the car wash, took a water hose to it, cleaned it off, and no more vibrating...


that happened to me last year, it was driving me nuts trying to figure it out!

Djv1389 04-03-2013 03:19 AM

I used to run K&N air filters and a couple of times installed the filter with to much oil and it gummed up the throttle body and caused a rough idle cleaned all sensors and throttle body and it was fine.started to use shop vac with a rag after that to make sure no extra oil was on the filter.


All times are GMT -5. The time now is 02:21 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community