Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Suspension/Driveline/Brakes/Wheels/Tires (http://www.jeepgarage.org/f109/)
-   -   Need help (http://www.jeepgarage.org/f109/need-help-57569.html)

tashakirkham 04-01-2013 03:01 PM

Need help
 
Hey all I have a 2012 laredo that I upgraded to the 20" oem wheels and 275 55 20 zeons. The first set of zeons we couldn't get to balance so we switched them out for a second set. Same problem. I took it to the dealership several times for a road force balance and alignment and we couldn't get it them to stay balanced. I then changed from the zeons to some Yokahama's thinking it may be the oversized tires. Same problem. Now I just purchased a 2nd set of brand new OEM wheels and I am still having problems with a shaking / vibrating steering wheel over 60mph. Dealership can't figure out whats going on and I am getting tired of spending tons of money. The 20's are hubcentric so I won't need a ring right? Lugs are fine coming from a laredo right? Weights aren't falling off and it doesn't seem the wheel is moving in the tire. Any help would be greatly appreciated!

SRT ROB 04-01-2013 04:37 PM

Re: Need help
 
If you've changed wheels then that would rule them out, you could have a look at the discs or drive shafts, is anything loose or damaged, I'm sure you tyre bloke would of checked the surface of the disc to make sure it's dead flat. I had a similar problem on my 300c, in the end it was a very slighty buckle rim, not noticable when you balanced it, only when I had them diamond cut it showed up.

Hope you get it sorted, I know how annoying it is.


All times are GMT -5. The time now is 07:39 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community