Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Transmission goes into "limp" mode (http://www.jeepgarage.org/f107/transmission-goes-into-limp-mode-57770.html)

RKlimas 04-04-2013 07:51 AM

Transmission goes into "limp" mode
 
I was just starting to accelerate on the entrance ramp to an expressway in the Chicago area and my transmission becomes stuck in 4th gear. Then the MIL illuminates. I was now in "limp" mode. Took it to the dealer yesterday and was told a solenoid went bad. Hope that is all it is. Should be picking it up today.

padgett 04-04-2013 01:44 PM

Re: Transmission goes into "limp" mode
 
Sounds reasonable but without the trouble code cannot say much. Hope the dealer is right.

Taws600 04-04-2013 04:35 PM

What year and engine? How many miles on your truck?

RKlimas 04-04-2013 06:59 PM

Re: Transmission goes into "limp" mode
 
Update-

Got the 2012 Jeep GC back today. It has the 5.7L engine. Threw Code #P0750- Solenoid failure. The dealer fixed it under warranty. I have 26,250 miles on it. Runs great. If in the Chicago area- Napleton's at River Oaks is a very good dealer to work with.

padgett 04-04-2013 10:59 PM

Re: Transmission goes into "limp" mode
 
Thank you - LR Solenoid failure 65RFE (Hemi) trans. Had to remove the pan and valve body to get at it. Sounds like a good dealer.

falcon_o 04-15-2014 12:10 PM

Re: Transmission goes into "limp" mode
 
Quote:

Originally Posted by RKlimas (Post 796029)
Update-

Got the 2012 Jeep GC back today. It has the 5.7L engine. Threw Code #P0750- Solenoid failure. The dealer fixed it under warranty. I have 26,250 miles on it. Runs great. If in the Chicago area- Napleton's at River Oaks is a very good dealer to work with.

@ 59,000, 4/2/14, had the exact same problem/code/solution on my 5.7L 2012 JGC.

Curious if this is indicative of a design flaw with this part.

mjlemon 06-24-2014 01:29 PM

Re: Transmission goes into "limp" mode
 
I have the exact same problem over the last 3 weeks. First they replaced the TIPM Module, then a shift Module, and it's back again for a third time. I suspect they will replace the Solenoid. Jeep is covering all of it. This is for a 2011 Jeep GC Overland 5.7, 53,000 miles. From what I've discovered, it seems the TIPM and Solnoids are defective and should have been part of a recall.

mjlemon 07-09-2014 08:01 AM

Re: Transmission goes into "limp" mode
 
CEL went off after engine turned off when I dropped off car at dealer and dealer refuses to replace solenoid even though there's a stored error code because there isn't an active error code from the car automatically going into 4th when shifted into drive. So I took it to another dealer and paid $700 to put in new solenoid. Warning--If your car goes into limp mode leaving running at the dealer or you loose the active code. If it fails again I'm trading for a Lexus SUV. I've given up on Jeep.


Sent from my iPhone using JeepGarage


All times are GMT -5. The time now is 04:25 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community