Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Help, Feels like no power is being transerred to front wheels (http://www.jeepgarage.org/f181/help-feels-like-no-power-is-being-transerred-to-front-wheels-58357.html)

airmech 04-14-2013 02:53 AM

Help, Feels like no power is being transerred to front wheels
 
Hey all,
I'm new to this and have a 2005 Jeep Grand Cherokee Limited in which seems like mint condition with a few normal bugs.

My problem seems to be that i'm not getting power to the front wheels.
This is my first jeep owned and not sure of the normal feel of driving.
I have no codes thrown and when I drive in snowy conditions the back end wants to kick out. To me that doesn't feel normal.

I have changed the fluid in the T-Case and don't have any abnormal sounds when driving.

Could low front diff fluid possibly cause this? Maybe front diff isn't locking and only have one wheel spinning.
other than that the jeep drives good

Thank you for any advice

airmech 04-14-2013 12:04 PM

Re: Help, Feels like no power is being transerred to front wheels
 
This is also the first time ive been in snowy/icy conditions with it.
I did change the rear fluid and solenoid when I had the "service 4x4 system" light came on about 2 months ago. That fixed that.
But now there are no abnormal sounds or vibrations or codes or warning lights. When I get a chance I will lift the jeep and spin the wheels to check if the diff and front driveshaft are moving.

2005JGC 04-15-2013 06:39 PM

Re: Help, Feels like no power is being transerred to front wheels
 
Did you install Mopar LSD additive to the rear diff? If not the clutches in the rear end will bind up, on snow it will just cause the rear end to slip around more if the inside and the outside wheels cannot differential.

airmech 04-15-2013 11:09 PM

Re: Help, Feels like no power is being transerred to front wheels
 
yes, I changed the rear fluid with the mopar 75-140 and the little bottle of additive. also changed the rear solenoid (due to "service 4x4 system" fault. code cleared after that. that was 2 months ago and no problems since. the T-case fluid was also changed around the same time with Mopar fluid Nv245. I also changed trans fluid and filters, just for routine maint. not due to problems. I've only noticed this issue due to the fact we now have snow on the roads and never had the chance to notice this.
so to clarify say im stopped at a stop sign trying to turn left. When I proceed to turn the back end wants to kick out and wants to do a doughnut.
it just feels like the front end is not pulling me through if you can understand that. Im not punching it, just decent acceleration. I have fairly new most season tires. It just feels like the front end isn't pulling its weight. I don't have and noises or clunks or fault lights.
Today I changed the front diff fluid just to make sure, It didn't seem overly dirty but I will have to take out for a test run next time it snows as it has already melted, lol.
I did happen to see the front drivers wheel spin while on a gravel road with Esp off. So I know the driveline is connected.

airmech 04-15-2013 11:15 PM

Re: Help, Feels like no power is being transerred to front wheels
 
Ive only owned this jeep since Oct and maybe im just not familiar with the way it drives. It just doesn't seem normal to me.

4.whoa 04-16-2013 03:20 AM

Re: Help, Feels like no power is being transerred to front wheels
 
These do not have full power to both axles at all times unless you're in 4 lo. otherwise the transfer case just acts like a diff. when it's slick the rear will slip a bit because there's more weight on the front. at least until traction control kicks in. when I hit it from a light ,not even full throttle , the rear will kick out a little bit until the weight transfers and then the rear digs in ,& the front pulls more,getting it straight.

airmech 04-16-2013 02:46 PM

Re: Help, Feels like no power is being transerred to front wheels
 
It sounds like it maybe running normal then and im just not used to it. I guess i'm just used to the front diff locking in 4 HI


All times are GMT -5. The time now is 03:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community