Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intakes/Exhausts (http://www.jeepgarage.org/f108/)
-   -   Issues with your HEMI??? (http://www.jeepgarage.org/f108/issues-with-your-hemi-58993.html)

MICHIWK2 04-25-2013 10:47 AM

Issues with your HEMI???
 
I was wondering if any one else has had any type of issues with their HEMI in their WK2. I have already had to replace my water pump and (the dealership told me) i had a collapsed lifter on one of my valves.

If you have had any issues please share.

PB617 04-25-2013 12:26 PM

Re: Issues with your HEMI???
 
What year is your WK2? how many miles?

MICHIWK2 04-26-2013 05:32 AM

Re: Issues with your HEMI???
 
2011 GC...


It had between 25K and 35K on it when these issues popped up...

I am about to hit 48K here by the next tank of gas and have not had any other issues so far.

The Evil Twin 04-26-2013 10:22 AM

Re: Issues with your HEMI???
 
Had a faulty fuel injector plug on cyl #2. Thats all the history shows.

MICHIWK2 05-13-2013 08:48 AM

Re: Issues with your HEMI???
 
I was getting on the E-way this past weekend and my jeep stalled on me!!! I just rolled 48K mi.

I was talking with my brother in law about this. We have had high 60 low 70 degree weather for the past week or so and last couple days the weather had dropped down into the 40's. He thinks that the engine may have gotten a blast of cold air into the engine and the density of the cold air hit before the computer could make adjustments for Fuel to Air table thus stalling the motor. Is this a probable cause??? No engine codes were thrown either. (Had a full tank of gas too)

webspoke 05-13-2013 02:53 PM

Re: Issues with your HEMI???
 
I had 48k miles on my 2011 Hemi with no engine issues, it just ran, in temps from the teens to well over 100. I never even changed plugs at 36k which was in the maintenance schedule. I think your issues are unusual. Current has 15k miles, no engine issues either.

bill_de 05-13-2013 02:59 PM

Re: Issues with your HEMI???
 
Quote:

Originally Posted by MICHIWK2 (Post 822167)
I was getting on the E-way this past weekend and my jeep stalled on me!!! I just rolled 48K mi.

I was talking with my brother in law about this. We have had high 60 low 70 degree weather for the past week or so and last couple days the weather had dropped down into the 40's. He thinks that the engine may have gotten a blast of cold air into the engine and the density of the cold air hit before the computer could make adjustments for Fuel to Air table thus stalling the motor. Is this a probable cause??? No engine codes were thrown either. (Had a full tank of gas too)

No. If that were the case cars would be stalling all over the place.


---

MICHIWK2 05-13-2013 03:33 PM

This is true... Just a blip in the computer?

BuckeyeSRT 05-15-2013 10:21 AM

Re: Issues with your HEMI???
 
I am at about 42K milage and I have noticed the last few thousand miles that my Hemi has gotten much more loud just before the transition from 4-8 cylinders(don't know the technical term) . It is really starting to get annoying.

MICHIWK2 05-15-2013 10:29 AM

Re: Issues with your HEMI???
 
When it switches to Economy mode???I can not even tell a difference when it switches to 4 cyls. (based on sound) Where is your sound coming from? the engine? Trans?

BuckeyeSRT 05-15-2013 10:30 AM

Re: Issues with your HEMI???
 
When it switches from ECO to 8Cyl(hitting a slight incline on the freeway for example) I could never tell the difference for the first 30K miles either.

MICHIWK2 05-15-2013 10:58 AM

You have the srt8? It could just be that motor breaking in ;-)


All times are GMT -5. The time now is 06:46 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community