Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   UConnect 5.0 software update. (http://www.jeepgarage.org/f107/uconnect-5-0-software-update-59380.html)

JeepersCreepers 05-02-2013 01:41 PM

UConnect 5.0 software update.
 
Hi guys, apologies if this has been posted but I didn't see anything on the first or second page. For those with UConnect 5.0 (and perhaps 8.4?), an update has been made available that you can actually do yourself:

https://rsur.extra.chrysler.com/rsur/Uconnect.do

The current release date shows as being 5/1/2013.

For the 5.0, the PDF containing the instructions says the update contains "Improvements to Phone Pairing capability" and "Increased ease of use". The former is apparently a fix relevant to TSB 08-028-13 (
"RA2 PAIRED PHONE LIST IS DELETED AFTER IGNITION CYCLE"), which was issued on 4/25. I've experienced this problem since I first got the vehicle and I just assumed it was my phone (which is non-iPhone/Android). I'm curious to see what the "increased ease of use" changes bring...

nikon858 05-02-2013 02:40 PM

Re: UConnect 5.0 software update.
 
No updates come up when I put in my VIN, I have the 8.4 though.

HeadShrinkerMD 05-02-2013 02:42 PM

Re: UConnect 5.0 software update.
 
I did this update the other day. Very simple. Iphone pairing issue totally resolved.

loveracing1988 05-03-2013 05:03 PM

Re: UConnect 5.0 software update.
 
Thanks for posting this! While I was sitting at the dealer last friday I went to this website on my phone and it said I had a update available, so I asked about it and they said they would hook it up to the computer and see if there was anything, it said there wasn't an update available, which I thought was weird. I'm thinking someone jumped the gun or something with it.

loveracing1988 05-03-2013 06:36 PM

Well, i tried to go install it, turns out the dealer must have updated it and not told me. Now the menus are changed a little and I now have the ability to enable and disable drl's like what is on the 8.4 " radio, I lost the ability to turn the hill start assist on and off though...

JeffC 05-03-2013 07:39 PM

Re: UConnect 5.0 software update.
 
I have a 2013 Laredo E with the RA2 - Uconnect 5.0 I assume. I've already had the phone pairing issue corrected by the dealer and it works fine; but I am curious about the "increased ease of use" so I wanted to see if I should update.

When I input my VIN on the Uconnect page I see that the update is listed, along with a link to the instructions. But...the model radio shown in pictures in the instructions is slightly different that what I have in my Jeep. In place of a settings button as shown in the instructions, I have a 'Climate' button.

I have a +More button just like the model shown in the pictures in the instructions, and when I press there I can access a 'Settings' menu, but scrolling through that menu don't have the 'System Information' selection shown in the pictures.

Anyone have this version of radio and know how to check your SW version?

Thanks, Jeff

loveracing1988 05-03-2013 07:44 PM

Quote:

Originally Posted by JeffC (Post 816763)
I have a 2013 Laredo E with the RA2 - Uconnect 5.0 I assume. I've already had the phone pairing issue corrected by the dealer and it works fine; but I am curious about the "increased ease of use" so I wanted to see if I should update.

When I input my VIN on the Uconnect page I see that the update is listed, along with a link to the instructions. But...the model radio shown in pictures in the instructions is slightly different that what I have in my Jeep. In place of a settings button as shown in the instructions, I have a 'Climate' button.

I have a +More button just like the model shown in the pictures in the instructions, and when I press there I can access a 'Settings' menu, but scrolling through that menu don't have the 'System Information' selection shown in the pictures.

Anyone have this version of radio and know how to check your SW version?

Thanks, Jeff

2013's didn't come with the ra2 radio... Mine isn't like pictured either and the software version isn't anywhere in there either, I just plugged the flash drive in and it says what you have and what it would go to, if the numbers match you are up to date.

JeffC 05-03-2013 08:14 PM

Re: UConnect 5.0 software update.
 
Thanks for the response & sorry for my typo - I do have a 2014.

JeepersCreepers 05-05-2013 06:04 PM

Re: UConnect 5.0 software update.
 
Quote:

Originally Posted by loveracing1988 (Post 816764)
2013's didn't come with the ra2 radio... Mine isn't like pictured either and the software version isn't anywhere in there either, I just plugged the flash drive in and it says what you have and what it would go to

Likewise. :)

loveracing1988 05-09-2013 03:30 AM

I'm so glad that Chrysler came out with a update. It sure wasn't perfect before but now we are having issues with my wife's phone disappearing altogether and she has to re-pair it every time she gets in it... Thanks Chrysler!


All times are GMT -5. The time now is 10:01 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community