Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intakes/Exhausts (http://www.jeepgarage.org/f108/)
-   -   Just had a major issue with my Hypertech interseptor (http://www.jeepgarage.org/f108/just-had-a-major-issue-with-my-hypertech-interseptor-59529.html)

2011hemigc4me 05-05-2013 09:38 PM

Just had a major issue with my Hypertech interceptor
 
Lost complete power on highway and was able to pull off safely. Upon review the module was melting. Under hood tempeture was normal since it was 65 no humity out. Very disappointed since I've been a huge advocate of this product. Let see what hypertech has to say. Listed bellow are some images of the module. I had this installed for a little over three months with out issue.:confused:

https://picasaweb.google.com/1030926...eat=directlink

Robert Palmer 05-05-2013 10:39 PM

Re: Just had a major issue with my Hypertech interseptor
 
There is no reason to be using anything other than Diablosport for tuning. Hypertechs are known to be overpriced pieces of shit.

Get yourself a Diablosport trinity and then contact Johan (diablotoona) for a custom tune.

CMil527 05-05-2013 10:48 PM

Re: Just had a major issue with my Hypertech interseptor
 
Sorry to hear man, keep us posted as to what happens with this!

XLR8R 05-06-2013 07:12 AM

Quote:

Originally Posted by Robert Palmer (Post 817715)
There is no reason to be using anything other than Diablosport for tuning.

No reason, unless of course you consider the countless threads of user complaints, problems, and issues with the current diablo tuners - many/most which are being met with little to no response or fixes.

And the fact that the canned tunes provide little to no performance benefit over the hypertech yet at a higher cost, both upfront cost for the device itself, and again after the sale ( when you get caught at the dealer and your warranty claim gets denied) and when you have to pay yet again for a custom CMR tune.

Not to mention, for 2013+ users there is STILL no support or handheld tuner available. So if for mo other reason, this is still the only game in town for some of us, and it does work for improving performance.

Not saying in the long run you wont get more out of a diablo tuner, but "more" in this case isnt all the good kind - more options, more performance maybe - more issues, headaches, and cost - definitely...

I plan to get a diablo if even for nothing more than shift points and data logging, but 1st It needs 2013 support and 2nd I want to see much better response from both the public/ users and the company themselves..

Robert Palmer 05-06-2013 11:06 AM

Re: Just had a major issue with my Hypertech interseptor
 
Quote:

Originally Posted by XLR8R (Post 817864)
No reason, unless of course you consider the countless threads of user complaints, problems, and issues with the current diablo tuners - many/most which are being met with little to no response or fixes.


And the fact that the canned tunes provide little to no performance benefit over the hypertech yet at a higher cost, both upfront cost for the device itself, and again after the sale ( when you get caught at the dealer and your warranty claim gets denied) and when you have to pay yet again for a custom CMR tune.


Not to mention, for 2013+ users there is STILL no support or handheld tuner available. So if for mo other reason, this is still the only game in town for some of us, and it does work for improving performance.

Not saying in the long run you wont get more out of a diablo tuner, but "more" in this case isnt all the good kind - more options, more performance maybe - more issues, headaches, and cost - definitely...

I plan to get a diablo if even for nothing more than shift points and data logging, but 1st It needs 2013 support and 2nd I want to see much better response from both the public/ users and the company themselves..


Go onto the diablosport forums and Mike or Johan themselves would help you fix your issue.

The trinity, yes is more than the hypertech, but if you get the intune, its 389 and some vendors have a discount on it. Hypertech is like 370 IIRC. You just have to look for it. And as far as getting caught, unless you leave your Custom Tune on the PCM when you go into the dealer, you arent going to get caught. And you dont pay again for the CMR tune, if you have an issue where the dealer updated your pcm, contact your tuner and they will help you out. You have to reflash the car back to stock when you bring the Jeep in for service. And make sure you have the CMR files. You do that, its simple as 1,2,3 to go back to your tune once you leave the dealer.

Yeah man you just have to wait for the 2013. These codes arent easy to crack for these tuners since they do change.

Hypertechs for years I have seen them BRICK PCM's. Threads all over the Jeep forum world on that. Diablosport is far more advanced and thats why its preferred.

They will get support for the 2013's, just be patient and once they do, contact your tuner of choice and get a CMR tune. It is really an upgrade over the canned tune.

BuckeyeSRT 05-06-2013 01:02 PM

Re: Just had a major issue with my Hypertech interseptor
 
Geez guys lighten up. If I fried my module and showed a pic here, the last thing I would want would be someone to now call my tuner a POS.

2011hemigc4me 05-06-2013 01:31 PM

Re: Just had a major issue with my Hypertech interseptor
 
Lol... He just stating his opinion and he from my neck of the woods. I jumped on the hypertech wagon one week before I found out about Diablo dcx . Up until this point I have enjoyed all the product promised. Just got of the phone theirs sending me a new one.,and will fill me in on what went wrong with the fried one.

Robert Palmer 05-06-2013 02:08 PM

Re: Just had a major issue with my Hypertech interseptor
 
Quote:

Originally Posted by BuckeyeSRT (Post 818093)
Geez guys lighten up. If I fried my module and showed a pic here, the last thing I would want would be someone to now call my tuner a POS.

Quote:

Originally Posted by 2011hemigc4me (Post 818119)
Lol... He just stating his opinion and he from my neck of the woods. I jumped on the hypertech wagon one week before I found out about Diablo dcx . Up until this point I have enjoyed all the product promised. Just got of the phone theirs sending me a new one.,and will fill me in on what went wrong with the fried one.

Sorry for sounding so harsh.

I'm just sick of seeing people having these catastrophic issues with those hypertech tuners.

Scottina06 05-06-2013 02:09 PM

Re: Just had a major issue with my Hypertech interseptor
 
so it wasnt heat from the engine bay?

parrish 05-06-2013 02:25 PM

Re: Just had a major issue with my Hypertech interseptor
 
I've had my Interceptor installed for a few months as well and have been loving it. However, as I was driving to my store this afternoon, I had a similar experience to the OP. I was driving down the highway and had let off the throttle for a red light. As soon as the light went green and I tried to accelerate- nothing. All power had been lost. I was able to get over to the side of the road (thankfully!) and tried to start it back up. It would start then immediately die. If I kept my foot on the gas after it started I could get it to keep running.
Went under the hood and disconnected the tuner (thankfully it's very easy) as well as the throttle harness. Fired right up and I was able to make it to my shop after that- although with less power because the CEL is on.

I did check the tuner module itself and it's not melted or even warm like the OP. Still, something not right.

Once I get home I'll hook it up to my diagnostic tool to see what codes its throwing. I'll clear the codes and make sure it's back to full power. Once that's done I'll try hooking the tuner up again to see what happens.
I'm just very glad this thing is easy to disconnect. Otherwise I'd be stranded on the side of the highway!

parrish 05-06-2013 05:12 PM

Re: Just had a major issue with my Hypertech interseptor
 
I discovered the root cause of the issue I was facing with my Interceptor. On Saturday I had my GC fully detailed- which included cleaning the engine bay. I hadn't driven the Jeep other than driving it home from the detailing.

When I pulled the Interceptor module out from under the engine compartment fuse box I didn't notice anything wrong with it at all- other than there being a spot of moisture on the bottom. I took the 4 screws out and opened it up- expecting to find burned up circuitry or some such damage similar to what the OP is showing. Nope- instead a good cup of water came pouring out! The box was nearly completely full of water. I have no idea how it ran at all- I drove it a good 30 minutes before any symptoms appeared.
Drained out all the water and cleaned the circuit board with electronic cleaner (something I keep in stock as I own a computer store and do a lot of circuit board repair). There was no visible damage to the board- no damaged circuits or anything like that (thankfully!). Reassembled the unit and popped it back in the Jeep. Cleared the codes with my Actron scantool (I didn't not the three codes but they were all related to throttle position). Runs perfectly once again and has all the power and improved drivability from the Interceptor.

One thing I am working on is weatherproofing that module. From the factory it's not even remotely weathertight- much less waterproof. No seals or gaskets to speak of. I'm going to use black RTV silicone to seal it up. I also added a couple more drain holes to the bottom of the fuse box itself. There were drain holes already there but, apparently, not enough.

This is something that absolutely should have come from Hypertech at least made somewhat weathertight.

BTW, I also discovered a mini-usb port on the board inside the box. I used Hyptertech's tuner update app to check for any updates. No updates at this point but at least now I know it's a possibility (I already knew the throttle sensor module had that USB update port).

XLR8R 05-06-2013 05:18 PM

wow - having a clean car almost killed you!

Agreed that box needs some weatherproofing..
Now that you mentioned it I'm on it...

Glad u and ur interceptor are ok!


All times are GMT -5. The time now is 05:20 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community