Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Starting problems (http://www.jeepgarage.org/f181/starting-problems-59570.html)

Island Hemi 05-06-2013 01:20 PM

Starting problems
 
He everyone, I have a 2005 hemi that has some issues. From time to time I will try to startit and it will start fine but then cut off. If I just wait a while, it will start again and be completely fine. When it does this it show all the service light, check engine, elec brake, 4wd system. What I don't understand is that everything just goes away after like nothing happened. This is getting very frustrating, especially when my wife borrows the car and then gives me shit because it has issues in some parking lot. Where I live there aren't any jeep dealers that I can take it to. I'm in the Caribbean. I tried the key trick to see if any codes pop up, but all it says is DTC REPORT _ _ _ _ _ _. Nothing shows up, I'm a little confused but I am really to just make an order to try to resolve this problem. Another thing is that the fuel quality isn't the greatest here, so I was thinking of getting the diablo tuner to make it work on 87, don't know of that would help. I have also read a lot on here about the o2 sensors which I plan on getting. Any help would be appreciated, thanks in advance for your assistance on this.

Island Hemi 05-07-2013 08:57 AM

Any ideas???


All times are GMT -5. The time now is 08:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community