Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   CRD no more power (http://www.jeepgarage.org/f181/crd-no-more-power-59667.html)

jeeper_57 05-08-2013 04:25 AM

CRD no more power
 
Hi all
Yesterday i get a strange problem on my 2005 CRD .
I've driven it in the morning , no problem, then after lunch I took it again ..
But no more power , meaning 40-60 km H max , no more turbo boost ...:eek::eek:
I get the check engine light on .
I've tried disconnecting MAF sensor ,it worked ,and turbo was working again,
I check the MAF , connected again , it worked 30 sec , then no more power , I disconnected the MAF no way to get power :mad:

I went to a wokshop with Diag ... and there is no way to see the defaults ..

Has anyone any idea of what it can be?

jeeper_57 05-13-2013 02:13 PM

Re: CRD no more power
 
Found it :)

Swirl motor failure, i used the resistor to go out of limp mode.
Does any one know how the swirl flaps are when themotor fail? opened or closed??


All times are GMT -5. The time now is 11:04 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community