Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WJ (http://www.jeepgarage.org/f51/)
-   -   Wj transmission problem (http://www.jeepgarage.org/f51/wj-transmission-problem-60127.html)

BalliN ShaQ 05-16-2013 04:11 PM

Wj transmission problem
 
Ok I have a 4.7 4x4 that runs great... Sometimes.... Lately when I'm driving my transmission starts to give me problems when I start it everything is Fine until I am ready to move. When I shift into drive the transmission jerks and when I put my foot down to move... I barely move.. Then I found out the it is pulling from 3rd gear... Any idea what u think the problem could be.... I'm thinking that it is the solenoid... All the help would be appreciated!

GreenWithEnvy801 05-16-2013 05:15 PM

Re: Wj transmission problem
 
mine did the same thing it ended up being that it was low on fluid.mine would do that when it was cold and as soon as I turned it off once it was starting to warm up and turn it back on it acted fine.

Frango100 05-17-2013 07:08 AM

Re: Wj transmission problem
 
The transmission seems to be in limp mode. You need to have it scanned to see which fault the TCM has stored. But first check the TCM fuse and relay in the power distribution center under the hood.

honda_fox3 05-24-2013 09:09 AM

Re: Wj transmission problem
 
I have a tranny I'll sell ya cheap! :)

TimYoung 08-18-2013 10:59 PM

Re: Wj transmission problem
 
Mine did same thing including shut it off and restart, it would be fine. Codes included ineffective clutch material on clutch 2. So it would start in 3rd. Had to be overhauled. I went a cheaper route with a swap out.


All times are GMT -5. The time now is 02:03 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community