Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f183/)
-   -   4.7l misses at start up (http://www.jeepgarage.org/f183/4-7l-misses-at-start-up-60184.html)

sunflower 05-18-2013 10:01 AM

4.7l misses at start up
 
2005 4.7l with 93000m klms. misses after start up,gets great mileage on highway and idles smooth as silk after warm up,just seems weird,only have it for 3000 klms.so still getting used to the beast.Anything to check or worry about?

2005JGC 05-20-2013 06:21 PM

Re: 4.7l misses at start up
 
is it actually misfiring, or just idles rough, do you have a check engine lamp on? The 4.7l is known to have a bit of a rough idle at times, mine comes and goes. Never get a check engine lamp, last I checked I was not even getting any misfire counts on any cylinders and I haven't cared enough to recheck since then.

sunflower 05-24-2013 10:47 AM

Re: 4.7l misses at start up
 
Thats what mine seems to do,when it is doing it seems to be a regular thump thump thump,then after running awhile become normal sounding.Don't know if it has thrown a code or not,no check engine light either.Didn't know about rough idle reputation.Thanks.:thumbsup:

harricanfloyd 10-05-2013 07:37 PM

Re: 4.7l misses at start up
 
You've probably got a bad coil. It misfires when cold and when it warms up it's fine. My mustang does the same thing.....especially when it hasn't run for a week or so. I know it's a coil, but since it smooths out, I won't bother with it until it completely fails. When it does, it'll be easy to tell which one it is...

korrupt_jeep 10-09-2013 10:22 AM

Re: 4.7l misses at start up
 
Just clean your (IACV) idle air control valve whit carburetor cleaner :thumbsup:


All times are GMT -5. The time now is 05:12 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community