Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   help oil pressure!!!! (http://www.jeepgarage.org/f196/help-oil-pressure-6031.html)

josef15111 01-30-2010 11:10 AM

help oil pressure!!!!
 
Hey guys just as the title states i need some help here. ok the deal is my wife got up this mourning to go do a job, wel she called me 5 mins after leaven saying the check gauages light was on! i was like ok check them lol she read them all off to me and then she seen the oil pressure she said it was on '0'!!! i was like o shit is it ticking anything like that she said no it sounds good and normial it drives good also no weird sounds. ok so she said as she drives it goes up to around halfway mark but once let off the gas it starts to fall again>? now is this a oil pump going out or what lol anyone ever had this happen>? also around 6 months ago i was driving and i went to fill up filled up and started to head out when i looked at my oil pres it was almost allll the way up on high!!! i started thinking wtf happen here. so i pulled over and checked the oil blah blah blah all was ok and good, started driving it was still high then it just went to normal after a few mins of driving. im thinkg the sensor i sgoing out let me know guys if this has happen to you


2001 4.7 v8 qudradrive just hit 120000 also ewwwww i didnt wanna see 120 yet lol

mon_21 01-30-2010 11:34 AM

Re: help oil pressure!!!!
 
Went to a car wash everything was fine, after I left, my oil pressure went down to zero, engine was performing fine, no hesitation, no nothing

I checked the oil pressure sensor and found out that there was a mixture of oil/dirt that built up on it.... bought some electrical spray can and sprayed the suckers off.
Havent had a problem since then, and that was 2 change oil cycles ago...

josef15111 01-30-2010 11:54 AM

Re: help oil pressure!!!!
 
you know what man i just went threw the car wash about 3 days ago and havent really drove to much since. hmmmm i bet its a wire or something tho. i have been searching and i have found a lot lot lot of people saying the same thing lol. i dont beleave my oil press is really low i dont hear anything that dont sound normal so i will take a peak under there when she gets home and i will clean it up a bit prolly just buy a new one and replace it only a few bucks. thanks for the speedy reply


Joe

mon_21 01-30-2010 11:59 AM

Re: help oil pressure!!!!
 
yeah its not an expensive part and not a difficult thing to change, good luck man.....

josef15111 01-30-2010 12:06 PM

Re: help oil pressure!!!!
 
yeah i changed the one on my mother in laws zj a few years ago she had the same problem. just seems whenever you get the cash to start making your baby come to life things have to go wrong dont they! lol i have a nice list of performace parts and things like that to buy i really dont wanna have to do a oil pump also lol. by the way where is the oil pump located on the 4.7? is it where the timing chains are? kinda looks like it from the pic of the pump. just wondering

Texas Jeep 01-30-2010 04:03 PM

Re: help oil pressure!!!!
 
Quote:

Originally Posted by josef15111 (Post 141311)
Hey guys just as the title states i need some help here. ok the deal is my wife got up this mourning to go do a job, wel she called me 5 mins after leaven saying the check gauages light was on! i was like ok check them lol she read them all off to me and then she seen the oil pressure she said it was on '0'!!! i was like o shit is it ticking anything like that she said no it sounds good and normial it drives good also no weird sounds. ok so she said as she drives it goes up to around halfway mark but once let off the gas it starts to fall again>? now is this a oil pump going out or what lol anyone ever had this happen>? also around 6 months ago i was driving and i went to fill up filled up and started to head out when i looked at my oil pres it was almost allll the way up on high!!! i started thinking wtf happen here. so i pulled over and checked the oil blah blah blah all was ok and good, started driving it was still high then it just went to normal after a few mins of driving. im thinkg the sensor i sgoing out let me know guys if this has happen to you


2001 4.7 v8 qudradrive just hit 120000 also ewwwww i didnt wanna see 120 yet lol

Yeah mine has the same problem except mine is a 4.0L. I've been driving it around like that for about three weeks but ill probably take out the oil pressure sensor tomorrow and spray it down with a cleaner like Mon_21 did.

Sodelcustoms 01-31-2010 06:17 PM

Re: help oil pressure!!!!
 
Mine has been doing the same thing on and off since summer. It's fine now but not something I really worry about.

violant00 10-02-2010 06:58 PM

Re: help oil pressure!!!!
 
Got any idear where this sensor is?


Quote:

Originally Posted by Texas Jeep (Post 141436)
Yeah mine has the same problem except mine is a 4.0L. I've been driving it around like that for about three weeks but ill probably take out the oil pressure sensor tomorrow and spray it down with a cleaner like Mon_21 did.


Frango100 10-02-2010 10:12 PM

Re: help oil pressure!!!!
 
Hi Joe,
The oil pump on the 4.7 is installed directly on the crankshaft where the primary timing chain runs. Hopefully your problem is the pressure sending unit.

doublejz 10-03-2010 07:28 PM

Re: help oil pressure!!!!
 
most likely just a sensor issue. The sensor is right on the adapter where the oil filter goes on.


All times are GMT -5. The time now is 07:19 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community