Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   quadra-trac 2 issue (http://www.jeepgarage.org/f5/quadra-trac-2-issue-6033.html)

jacoppola 01-30-2010 12:58 PM

quadra-trac 2 issue
 
front wheels do not get power in either all time or low. what are some checks that I can perform?

Scottina06 01-30-2010 01:21 PM

Re: quadra-trac 2 issue
 
are you sure bro? Are you getting any codes etc?

ducks unlimited 01-30-2010 01:34 PM

Re: quadra-trac 2 issue
 
what the year and model is your jeep

Chaoul1 01-30-2010 08:23 PM

Re: quadra-trac 2 issue
 
You sure you have Quadra-Trac? You sure it isn't Select-Trac? Maybe the front drive shaft is disconnected....someone will chime in.

jacoppola 02-01-2010 12:50 PM

Re: quadra-trac 2 issue
 
It's a 99 grand cherokee. No error codes and the drive shaft is not disconnected.

LTrainGC 02-01-2010 02:18 PM

Re: quadra-trac 2 issue
 
Isn't quadra-trac II in the WJ variable with it's torque split? I think selec-trac is a 48/52 F/R split - but quadra-trac II will vary from 0/100 to 100/0 depending on conditions.

Have you been in a situation where you think the front wheels should be getting power but they arent?

scjeep4.7HO 02-01-2010 08:33 PM

Re: quadra-trac 2 issue
 
If you have checked to make sure that it is not working you either have a broken chain or a bad progressive coupler. You should have a NP247J T case. if it is the progressive coupler it is fairly expensive to replace and you may just want to use yours as a core return and get e rebuilt one or try the junk yard route.


All times are GMT -5. The time now is 09:08 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community