Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK2 - (http://www.jeepgarage.org/f73/)
-   -   2014 Overland broke down yesterday....had ot be towed. (http://www.jeepgarage.org/f73/2014-overland-broke-down-yesterday-had-ot-be-towed-60337.html)

Sleestak 05-22-2013 08:25 AM

2014 Overland broke down yesterday....had to be towed.
 
So yesterday, I started the Jeep with only 1200 miles on it. It stalled right away after turning over. Thinking maybe the cylinders misfired I started it again and it started as normal. Then while driving it, the check engine light came on almost immediately (blinking, not steady yellow) and had very little power when stepping on the gas. However, when the Jeep was at idol it was fine. I immediately pulled over and jeep was towed. No diagnosis as of yet. Anyone care to chime in what this could be? My service peeps are way cool! They gave me a 2013 Overland they had on the used car lot to drive around in the meatime...

Willx 05-22-2013 08:38 AM

Re: 2014 Overland broke down yesterday....had ot be towed.
 
Quote:

Originally Posted by Sleestak (Post 827109)
So yesterday, I started the Jeep with only 1200 miles on it. It stalled right away after turning over. Thinking maybe the cylinders misfired I started it again and it started as normal. Then while driving it, the check engine light came on almost immediately (blinking, not steady yellow) and had very little power when stepping on the gas. However, when the Jeep was at idol it was fine. I immediately pulled over and jeep was towed. No diagnosis as of yet. Anyone care to chime in what this could be? My service peeps are way cool! They gave me a 2013 Overland they had on the used car lot to drive around in the meatime...

Not sure if it means the same but in other manufacturers flashing engine light meant exhaust problem. Often a plugged CAT or something but I have never seen this on that low of miles.... I believe the flashing is more about severity than an actual diagnosis but when I have seen it it was exhaust. Even Throttle Body failures usually dont show as a flashing indicator...Possibly a Sensor issue but that is just a guess.

Chunderboy 05-22-2013 08:50 AM

Re: 2014 Overland broke down yesterday....had ot be towed.
 
Quote:

Originally Posted by Sleestak (Post 827109)
So yesterday, I started the Jeep with only 1200 miles on it. It stalled right away after turning over. Thinking maybe the cylinders misfired I started it again and it started as normal. Then while driving it, the check engine light came on almost immediately (blinking, not steady yellow) and had very little power when stepping on the gas. However, when the Jeep was at idol it was fine. I immediately pulled over and jeep was towed. No diagnosis as of yet. Anyone care to chime in what this could be? My service peeps are way cool! They gave me a 2013 Overland they had on the used car lot to drive around in the meatime...

Sorry to hear that bro. Let us know what you find out.

Copefree 05-22-2013 05:52 PM

Re: 2014 Overland broke down yesterday....had ot be towed.
 
Damnnnnn. Another '14 in the shop. I really hope my '14 Overland avoids these issues. 2,100 trouble-free miles so far.

Good luck. I'm looking forward to the update.

Specx 05-22-2013 06:39 PM

Re: 2014 Overland broke down yesterday....had ot be towed.
 
Which engine do you have?

marosenb 05-22-2013 06:47 PM

Re: 2014 Overland broke down yesterday....had ot be towed.
 
MY 14 limited v6 had issues, couldn't accelerate, then stalled out on the highway... they had to replace the catalytic converter. After I got it back, still wasn't right, couldn't accelerate, and they replaced the oxygen sensors. Third time it went in, they replaced the ABS module. Just got it back last night... hopefully that was the last fix needed. 3 trips to the dealer, about 21 days all told. Less than 1000 miles on it still.

I hope your issue is nothing like this, but the stalling out and now power sounds kinda similar.

weck 05-22-2013 10:06 PM

Only time I've ever had a flashing mil was an ignition coil failing, symptoms were similar as well. Idles fine but no power/would not rev very high.

padgett 05-22-2013 10:19 PM

Re: 2014 Overland broke down yesterday....had ot be towed.
 
Really need to know what codes were set, just guessing otherwise.

Marcodame 05-22-2013 10:40 PM

Sorry to hear all the problems u guys are having hopefully it all gets worked out, such a awesome truck kinda nervous about mine now whenever I get it.

jacko15 05-23-2013 09:10 AM

Re: 2014 Overland broke down yesterday....had ot be towed.
 
I'm wondering if the Jeep is kinda like a junkyard dog, and can sense fear!

Sleestak 05-23-2013 10:55 AM

Re: 2014 Overland broke down yesterday....had ot be towed.
 
If there's any silverlining, I'm glad these issues are happening early and not later once out of warranty...

CHALLENGERBIZJET 05-23-2013 11:44 AM

Jacko how's your jeep running ?


All times are GMT -5. The time now is 06:11 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community