Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Trailer lighting not working, Fuses not pushed in...Give me some help here (http://www.jeepgarage.org/f107/trailer-lighting-not-working-fuses-not-pushed-in-give-me-some-help-here-60448.html)

FD12ME 05-24-2013 08:24 AM

Trailer lighting not working, Fuses not pushed in...Give me some help here
 
I had a trailer hitch installed on my '14 WK2 yesterday. Mind you, it was pre-wired, but no hitch. I went to connect my trailer today and NO lights...its not the trailer-it lit right up for my tahoe, every light worked fine. I went to see if just perhaps Jeep had not included a fuse since my car didn't come with a hitch and found:
1. About 1/3 of the fuses were not engaged all the way (and I know Jeep does not engage them all when shipping so apparently my car was either never properly "delivered" or who knows...)
2. The trailer fuses were there, but according to the manual, one of them should be 20amp, the other 30amp. Mine had a 15amp and a 30amp.

Any ideas before I shelp over to the dealership and wait 2 hours for them to say..."uhhhh we dont know"

Dabitz 05-24-2013 08:50 AM

Re: Trailer lighting not working, Fuses not pushed in...Give me some help here
 
I believe this option has to be turned on by the dealership for it to work. I'm pretty sure someone will confirm, etc.

FD12ME 05-24-2013 09:17 PM

Indeed you are correct. Brought it in, problem solved. Thanks!

jeelo 05-28-2013 01:43 PM

Re: Trailer lighting not working, Fuses not pushed in...Give me some help here
 
Its stupid. You have to bring it in to the dealership for them to activate it. I fought with the service adviser because he wanted to charge me an hour ($135/hr + taxes) for something that would take their tech <10mins to do. Finally got him to change it to .25hr since I was already in their getting my 50k service done.

BobsWK2 05-28-2013 06:04 PM

Re: Trailer lighting not working, Fuses not pushed in...Give me some help here
 
Just about all late model (2011 and later) vehicles that have a tow hitch installed after the vehicle leaves the assembly line would require the tow hitch to be coded to the vehicle.

kbre 05-28-2013 06:11 PM

Re: Trailer lighting not working, Fuses not pushed in...Give me some help here
 
Quote:

Originally Posted by jeelo (Post 830412)
Its stupid. You have to bring it in to the dealership for them to activate it. I fought with the service adviser because he wanted to charge me an hour ($135/hr + taxes) for something that would take their tech <10mins to do. Finally got him to change it to .25hr since I was already in their getting my 50k service done.

That is borderline theft right there, The Jeep dealer here only charged me $30 to activate mine. No haggling required, I thought that was high.


All times are GMT -5. The time now is 08:44 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community