Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   (2014 Overland) wipers, headlights, one side LEDS dont work (http://www.jeepgarage.org/f107/2014-overland-wipers-headlights-one-side-leds-dont-work-60505.html)

Keirik 05-25-2013 05:35 PM

(2014 Overland) wipers, headlights, one side LEDS dont work
 
14 here with just over 1500 miles on it. The front wipers wont come on in any position, headlights wont come on at all, and drivers side LED DRL wont come on at all.

No CEL or anything and car seems to run fine. I cant really drive though since it's pouring here in NY all day today. Was all working just fine last night. I disconnected the battery to see if maybe a reset does the trick.

Mikessrt 05-25-2013 06:17 PM

Re: (2014 Overland) wipers, headlights, one side LEDS dont work
 
If your fuses are all seated properly, it may be a loose wire to the steering column control module.

Keirik 05-25-2013 09:06 PM

Re: (2014 Overland) wipers, headlights, one side LEDS dont work
 
I dont think a loose wire in the steering column would make the headlights not work or one side LEDs on the headlight not work either though. Can it?

Keirik 05-26-2013 12:18 PM

Re: (2014 Overland) wipers, headlights, one side LEDS dont work
 
EVIC also says Front turn signal isn't working.

Looked to think if i can change it myself but damn, sure looks like it's not as easy as older cars were lol

scooterha 05-28-2013 10:14 AM

Re: (2014 Overland) wipers, headlights, one side LEDS dont work
 
I wouldnt even attempt trying to fix that myself.. I think a dealer visit is in your future.

Keirik 05-28-2013 12:11 PM

Re: (2014 Overland) wipers, headlights, one side LEDS dont work
 
yeah, car is in the dealer. Worst time for this to happen because they had cars waiting over the two days service was closed on Sunday and for Memorial day so mine hasn't even been looked at yet.

Keirik 05-29-2013 04:03 PM

Re: (2014 Overland) wipers, headlights, one side LEDS dont work
 
Update
Fixed. BCM (not sure if that's the tech or a part) says one connection loose. Reseccured and everything works again.
:D


All times are GMT -5. The time now is 06:19 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community