Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   2014 In-Dash navigation errors (http://www.jeepgarage.org/f107/2014-in-dash-navigation-errors-60655.html)

f1anatic 05-29-2013 06:24 AM

2014 In-Dash navigation errors
 
2 Attachment(s)
I am making a separate thread about this condition because it is different than the symptoms reported previously. This time is with a perfectly working navigation (RA4).

For the purposes of this thread, I am going to refer to the in dashboard navigation as the part of the 7 inch display behind the steering wheel which provides route guidance. This usually shows generic intersections, a yellow arrow and has 3 lines of text: two for text and one for the distance.

A few days ago, on my car, the text input started being truncated. At first I got confused, and I thought there is a limit to the number of characters that can be displayed. Of course there is but that is not my top concern: the words get misspelled or truncated when it makes no sense to do so (meaning the words are shorter than the system's alphanumerical display limit)

Example # 1
Local Lanes
AddisoN <-- Letter "N" was missing
0.3mi

Example # 2
I-90 WB
Kennedy Ex <--- a lot more characters (3 plus a space) than in Example # 1
0.3mi

I have also documented entries like this:

Example # 3

Lee
St
0.1mi

as well as

Example # 4
Knox Ave

0.2mi

where the second level contains but 2 characters or none at all. And I do not remember this to be a problem. Might be the Alzheimer but in one month of ownership I have not noticed the text display there to be anything but accurate and complete. These problems appear to have started around last Tuesday-Wednesday - but the navigation system as a whole has not had a "freeze" nor there have been any momentary lapses in the GPS sensitivity (as previously reported). I have not applied the UPDATE yet (I have downloaded it from Chrysler ) as I am awaiting the results of Jeep's "investigation". Now, these symptoms appear to have started after the update became available...which goes on to further strengthen my and other people's suspicion that any "OTA updates" mess up the system. Except that this 370 mb update is not OTA but who knows, maybe the system knows about it.

I have not previously noticed street names being truncated in such a manner. Has anyone noticed the same?

Thanks.

PS: Car is at the stealership, getting its navi checked, oil changed.

f1anatic 05-29-2013 06:32 AM

Re: 2014 In-Dash navigation errors
 
1 Attachment(s)
Ah and while on the subject...of the in-dash display:

993 miles driven on the car
...
40631 mi Since Reset of the OIL LIFE indicator

:eek: they gave me an old engine ? Of course not. But it seems like my gauge cluster has been off the meds. Or maybe needs some :mad:

rcsimon 03-27-2014 07:04 AM

Re: 2014 In-Dash navigation errors
 
I have had my Diesel Grand Cherokee since January. At 2,600 miles I received a message stating that I had 5% oil life remaining. I took it the dealer who also was confused as to why the oil needed to be changed so soon. Everything that I have seen indicates that oil changes should be close to 10,000 miles. The dealer did not have a filter in stock so I agreed to have them reset the counter. As of today I have gone about 900 miles since they did the reset and the cluster is showing that I have approximately 51% of oil life left with under 4,000 miles on the vehicle. I have also noticed that with the engine off but in the ACC position the cluster is showing the same statement of 40631 mi Since Reset of the OIL LIFE . No one at Jeep can explain what is going on with this. Jeep did issue a TSB of 18-018-14a that is supposed to address the problem however, after having the flash update completed I have not noticed anything different.

Willx 03-27-2014 07:59 AM

There is a TSB and a PCM flash dealing with oil life and a number of possible communication errors with some other systems. I would start there.

rcsimon 03-29-2014 09:52 AM

Re: 2014 In-Dash navigation errors
 
That is what I mentioned in my previous post. However it does not seem to have done anything.

14SummitHemi 03-29-2014 12:19 PM

Re: 2014 In-Dash navigation errors
 
Quote:

Originally Posted by f1anatic (Post 830875)
I am making a separate thread about this condition because it is different than the symptoms reported previously. This time is with a perfectly working navigation (RA4).

For the purposes of this thread, I am going to refer to the in dashboard navigation as the part of the 7 inch display behind the steering wheel which provides route guidance. This usually shows generic intersections, a yellow arrow and has 3 lines of text: two for text and one for the distance...

Uh, I am sure I am missing something here but....You say you have the RA4 which means we have the exact same radio and nav...How the heck do you even get the nav display in your pics? I cannot for the life of me get it.

Okay folks, rip away on the dummy :D

norphaedrus 03-29-2014 02:26 PM

I've only had my 14 overland for 7 weeks or so and only used the navigation guidance once, but it showed up like in the pic only when a turn was approaching? If I was say 4 miles away it was displaying whatever option I had selected, mpg, radio, etc.

14SummitHemi 03-29-2014 02:38 PM

Re: 2014 In-Dash navigation errors
 
Quote:

Originally Posted by norphaedrus (Post 1000214)
I've only had my 14 overland for 7 weeks or so and only used the navigation guidance once, but it showed up like in the pic only when a turn was approaching? If I was say 4 miles away it was displaying whatever option I had selected, mpg, radio, etc.

Really, well, I use the nav a fair amount but can't say it does not show up in that instance so I'll pay better attention and report back....thx

norphaedrus 03-29-2014 02:45 PM

1 Attachment(s)
Also ensure that the option is checked in navigation settings.

Turn by turn in cluster.



Attachment 37570

14SummitHemi 03-29-2014 02:48 PM

Re: 2014 In-Dash navigation errors
 
Quote:

Originally Posted by norphaedrus (Post 1000222)
Also ensure that the option is checked in navigation settings.

Turn by turn in cluster.



Attachment 37570

Crikey! THAT's IT! Knew I was missing something, no way I could miss that graphic staring me in the face! Thanks a bunch.

AAAA 03-31-2014 07:57 AM

Re: 2014 In-Dash navigation errors
 
Quote:

Originally Posted by rcsimon (Post 998851)
I have had my Diesel Grand Cherokee since January. At 2,600 miles I received a message stating that I had 5% oil life remaining. I took it the dealer who also was confused as to why the oil needed to be changed so soon. Everything that I have seen indicates that oil changes should be close to 10,000 miles. The dealer did not have a filter in stock so I agreed to have them reset the counter. As of today I have gone about 900 miles since they did the reset and the cluster is showing that I have approximately 51% of oil life left with under 4,000 miles on the vehicle. I have also noticed that with the engine off but in the ACC position the cluster is showing the same statement of 40631 mi Since Reset of the OIL LIFE . No one at Jeep can explain what is going on with this. Jeep did issue a TSB of 18-018-14a that is supposed to address the problem however, after having the flash update completed I have not noticed anything different.

Your dealer did not have an oil filter in stock for a current model? :eek:


All times are GMT -5. The time now is 09:20 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community