Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Interior/Exterior/Visual (http://www.jeepgarage.org/f176/)
-   -   some quality issues... (http://www.jeepgarage.org/f176/some-quality-issues-60695.html)

mikoz 05-29-2013 05:45 PM

some quality issues...
 
Hi,

I have a 2012 Overland Hemi 4x2 with 15k miles.

I wondered if others are seeing these issues. Some of these are just things that can't be changed, but I wondered if others have had luck in getting them corrected:

1. horizontal chrome strip alignment on the outside door sills is, well, crappy and getting worse. The left rear door's chrome strip has taken a detour of at least 1/2" from the desired location and is getting worse. It seems that Jeep can't decide if the weather stripping around the outside perimeter of the windows is supposed to be tucked in or out... when we took delivery of it some doors had it tucked in, others had it tucked out.

--> has anyone had luck getting the dealer to address that type of issue? Or is this just a normal American car problem?

2. orange peel paint. I never really noticed until I did a good waxing, it's pretty bad especially around the rear quarters. Anyone else seeing this?

3. ventilated seats have already developed a small rip on the bottom cushion (primary driver is a small female who is quite gentle on the seats). In addition, in certain positions, you can hear the seat back material give way when you're seated, it sounds like there's newspaper behind the leather, it just seems like it's very poor quality but surely looks nice (well, expect for the tear).
--> has anyone had luck getting the dealer to address that type of issue?

4. Uconnect phone stability and quality. Sometimes it won't connect at all, the mic pics up and amplifies all of the ambient sound and sometimes the radio volume goes mute for no apparent reason. I have an iphone 4 and a 4s with the latest iOS and the same phones in other vehicles do not have this issue. We usually have to just give up on the handsfree if you plan to talk.
--> anyone else seeing this?

5. frequent refusal of the car to acknowledge button presses from the fob from distances of even just a few feet away. the range is unpredictable and not consistent, sometimes it won't work from even just 5 feet away in a vacant parking lot. I did replace the battery in the fob just to be sure.

6. we have black metallic paint (which I know is the worst for showing defects), but the chipping on the hood is getting out of control. We have had other cars with a similar color and similar road stance and the number and severity of the chips is really high on this car. I guess a paint depth meter would show very thinly applied paint.

Jakkall 05-30-2013 08:08 AM

Same for me in regards to those weather rubber things around the windows on the exterior . I tucked them in :)

peejym 05-30-2013 11:22 AM

Re: some quality issues...
 
Here is what came across,

1. Yes, the chrome strips on my also have what looks like tools marks, swirls on the ends, rubber strips were half in half out, I pulled all out and luckly with the sun baking on it seems to have removed move creases.

2. have no seens this but noticed allot of scratches on the paints I cann not remove, and along the black panels on the doord between the windows.

3. I do have damage i noticed on the pleather, seems like scrape marks on the back seats. The driver's side seat had all sorts of scratches (deep) ones on the plastic parts but dealer replaced it for me. I have the seat protection package so eventually I will hit them up for the back seats. have not noticed any tears and I am a big guy, but I will definately go look here during my lunch hour.

4. Uconnect issues seemed to have been resolved after I installed the new patch.

5. No fob issues, only thing was the 4 times press to open the gate but I found out that you have to unlock and then press twice to open the gate.

6. No chip thanks god, I have not done much hyway driving and now I might reconsider the xpel protection, but xpel is not cheap :(

BobsWK2 05-30-2013 07:39 PM

Re: some quality issues...
 
Quote:

Originally Posted by peejym (Post 831739)
Here is what came across,

1. Yes, the chrome strips on my also have what looks like tools marks, swirls on the ends, rubber strips were half in half out, I pulled all out and luckly with the sun baking on it seems to have removed move creases.

2. have no seens this but noticed allot of scratches on the paints I cann not remove, and along the black panels on the doord between the windows.

3. I do have damage i noticed on the pleather, seems like scrape marks on the back seats. The driver's side seat had all sorts of scratches (deep) ones on the plastic parts but dealer replaced it for me. I have the seat protection package so eventually I will hit them up for the back seats. have not noticed any tears and I am a big guy, but I will definately go look here during my lunch hour.

4. Uconnect issues seemed to have been resolved after I installed the new patch.

5. No fob issues, only thing was the 4 times press to open the gate but I found out that you have to unlock and then press twice to open the gate.

6. No chip thanks god, I have not done much hyway driving and now I might reconsider the xpel protection, but xpel is not cheap :(

1. My chrome mouldings around rear side windows also have scuff marks.
I just chalk it up to poor quality control.

2. There specs of what looks like dirt in the paint on 4-5 spots on my Summit.
Again, just poor quality control.

5. The keyfob is supposed to open/close the liftgate with 2 clicks on the
liftgate button. You shouldn't have to press the unlock button first, then
press the liftgate button twice. But this problem sounds like its starting
to show up in quite a few 2014 WK2's, amd will keep showing up until
Chrysler takes the time to find a cure. I'm not holding my breath.

GELOverland 05-31-2013 07:24 AM

Re: some quality issues...
 
I have the orange paint peel syndrome as well. Other than that, not one issue since I bought my Jeep in November 2011.

mikoz 06-04-2013 04:31 PM

Re: some quality issues...
 
Hi,

Dealer is replacing the trim and waiting for a response from Chrysler on the seats (I'm not holding my breath on that, however).

-mike

r2dsgn 09-29-2013 09:35 PM

Re: some quality issues...
 
Quote:

Originally Posted by mikoz (Post 831290)
Hi,

I have a 2012 Overland Hemi 4x2 with 15k miles.

I wondered if others are seeing these issues. Some of these are just things that can't be changed, but I wondered if others have had luck in getting them corrected:

1. horizontal chrome strip alignment on the outside door sills is, well, crappy and getting worse. The left rear door's chrome strip has taken a detour of at least 1/2" from the desired location and is getting worse. It seems that Jeep can't decide if the weather stripping around the outside perimeter of the windows is supposed to be tucked in or out... when we took delivery of it some doors had it tucked in, others had it tucked out.

--> has anyone had luck getting the dealer to address that type of issue? Or is this just a normal American car problem?

2. orange peel paint. I never really noticed until I did a good waxing, it's pretty bad especially around the rear quarters. Anyone else seeing this?

3. ventilated seats have already developed a small rip on the bottom cushion (primary driver is a small female who is quite gentle on the seats). In addition, in certain positions, you can hear the seat back material give way when you're seated, it sounds like there's newspaper behind the leather, it just seems like it's very poor quality but surely looks nice (well, expect for the tear).
--> has anyone had luck getting the dealer to address that type of issue?

4. Uconnect phone stability and quality. Sometimes it won't connect at all, the mic pics up and amplifies all of the ambient sound and sometimes the radio volume goes mute for no apparent reason. I have an iphone 4 and a 4s with the latest iOS and the same phones in other vehicles do not have this issue. We usually have to just give up on the handsfree if you plan to talk.
--> anyone else seeing this?

5. frequent refusal of the car to acknowledge button presses from the fob from distances of even just a few feet away. the range is unpredictable and not consistent, sometimes it won't work from even just 5 feet away in a vacant parking lot. I did replace the battery in the fob just to be sure.

6. we have black metallic paint (which I know is the worst for showing defects), but the chipping on the hood is getting out of control. We have had other cars with a similar color and similar road stance and the number and severity of the chips is really high on this car. I guess a paint depth meter would show very thinly applied paint.

Did you find any resolution on your radio issues? Did the iOS 7 update help in anyway?

I have had nothing but problems since I got my 2012. I hoped the iOS 7 update would solve it, but hasn't. The uConnect takes a while to connect, and when it does, the volume is sometimes muted (as you described). When streaming music, the music will drop (like skipping). Another user suggested turning off WiFi, but that didn't solve it for me. Also found the uConnect will sometimes drop the connection and reconnect randomly. Curious your experiences since your last post.


All times are GMT -5. The time now is 01:53 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community