Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Electrical problem... (http://www.jeepgarage.org/f77/electrical-problem-60725.html)

jesse3murray 05-30-2013 10:18 AM

Electrical problem...
 
I have a 2000 Cherokee sport, when I turn the key to the on position I have a surge through the fuse box under the hood. The ASD relay and fan relays turn on and off consistently. I've noticed the a/c clutch, the idler sensor on the throttle body and the fuel pump all do the same thing, turn on and off consistently while the key is in the on position. If I start the jeep it will fire right up, idles like crap for the first few seconds, but runs like there is nothing wrong. No skip, no nothing. Keep in mind the 4.0 has been rebuilt and bored .030 over. Brand new alternator and the bigger throttle body with the edge programmer hooked up. Any ideas of where to look?

jesse3murray 05-30-2013 10:20 AM

I have checked a couple grounds fuel pump, electric fan, and the top motor ground. Also if you pull out the fuel pump relay, all of the noises and ticking goes away and the electric fan engages and stays on... I'm lost

jesse3murray 05-31-2013 03:41 PM

Anyone have any ideas???


All times are GMT -5. The time now is 09:41 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community