Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Key fobs not working Grrr (http://www.jeepgarage.org/f77/key-fobs-not-working-grrr-61074.html)

Becheley 06-06-2013 05:32 PM

Key fobs not working Grrr
 
Hi all. I'm in the uk and found this site and am hoping this wil help me solve a year of grief and hassle as I just can't seem to get to the bottom of the mess!

Jeep grand Cherokee on 2004/05

At the start I was getting problems with the interior lighting. The lights on the cockpit were dim and I had to turn the light switch to full on the stick to get it to brighten up. But that meant having all interior lights on.

So I took the car to the local garage, he found a broken wire in the drivers door, he repaired the wire which then solved the problem.

However since then I have had no central locking and can only operate it from the drivers door button when getting out, and just using the key to unlock the drivers door getting in.

The chap said it needed re programming as the wires had been disconnected. So I took to a garage recommended by the main dealer as they don't do servicing.

They plugged in and the computer is receiving the signal of the key fobs and they re programmed it and it still doesn't work.

They say they can't tell me what the problem is without taking the car and investigating which I thinks bull!

I have googled a few bits and some people say maybe its the imobiliza antenna?

Not sure if its related but ever since I've had the car one of the remotes has been temperamental but the other was fine, however they both got tested and they say they are both sending signals and the Ecu is reading it. But just not locking or unlocking the car

Also I must add it all works when using the button on the drivers door.

The report from the garage says this

Try to programme CID for keys
Programme both fobs and works through drb inop on car.


I'm at a loss and the only option I have is to have an aftermarket central locking system fitted which will lock and unlock doors from new key fobs. Not sure it will still activate alarm etc though. I don't realy want to do that as I would rather keep it all original.

If I can't fix it I'm going to have to sell it as my wife is struggling with the locking etc with having to baby's in back its a right Pain in the arse as one she gets the kids out she needs to go back to drivers door and open it and press button to lock it. Also has to unlock drivers door then open door and press button on door just to unlock all doors.


Any suggestions would be so great full as I realy don't want to sell it but she's lost patience!

Please help!

Rich

:brickwall:brickwall

Frango100 06-09-2013 01:59 PM

Re: Key fobs not working Grrr
 
2004/05, is this still a WJ or already a WK?
The antenna for the remotes is just a piece of wire connected to the passengers door module. (at least its there on LH driven jeeps, not sure on RH driven jeeps).
Do all locks work from the drivers position? And from the passengers side?
Where the locks working normally before the wire in the door boot broke?
No power locks could also come from an other broken wire in the door boot. I would have a look in both drivers and passengers door boots and check for any broken wire. Are the power windows working ok?
Other than this, they could check the passengers door module using the Chrysler DRB III scanner.

Becheley 06-09-2013 02:15 PM

Re: Key fobs not working Grrr
 
Great thanks got the reply. I don't know what wj or wk means lol sorry?

All the locks work when I use the lock/unlock switch on the drivers door!

When I put the key in drivers door to unlock it only unlocks that door which I think is normal !?

It also all works from the passenger door!!

All the windows work fine!!

Any ideas? Its driving me insane!

Thanks for the help its much appreciated!!

2004/05, is this still a WJ or already a WK?
The antenna for the remotes is just a piece of wire connected to the passengers door module. (at least its there on LH driven jeeps, not sure on RH driven jeeps).
Do all locks work from the drivers position? And from the passengers side?
Where the locks working normally before the wire in the door boot broke?
No power locks could also come from an other broken wire in the door boot. I would have a look in both drivers and passengers door boots and check for any broken wire. Are the power windows working ok?
Other than this, they could check the passengers door module using the Chrysler DRB III scanner.

Frango100 06-09-2013 05:16 PM

Re: Key fobs not working Grrr
 
WJ = 1999-2004
WK = 2005-2010
Your problem seems to be with the passenger door module, which has the RF receiver which gets the signals from the remote controls. (its just a part of the module where the window switches are mounted on.) The question only is, with your jeep being right hand drive, if the unit is still on the passengers side (so left door in your case), or on your drivers side door module. Using the previously mentioned DRBIII scanner could tell more how the modules are working.
It could be that the respective module has a problem or even that the antenna wire broke of. You could try and use the remotes very close to where the window switches on the front doors are, try on left and on right door. If it would work in that case, then there is a good change that the problem is the antenna wire. If it still doesn't, most probably the problem is with the door module.

Becheley 06-12-2013 02:37 PM

Re: Key fobs not working Grrr
 
Thanks for your help . Can't locate any dealer by me or anyone with a scanner! Keep trying I guess! Gerrrrrr , thanks though much appreciated

Becheley 06-12-2013 05:27 PM

Re: Key fobs not working Grrr
 
Can you believe I disconnected the battery and reconnected and it all now works!! 6 garages including a main dealer couldn't do that! Thanks to this site I'm sorted! Thanks for your help mate

Frango100 06-12-2013 07:15 PM

Re: Key fobs not working Grrr
 
So most probably some component had locked up and was reset by the battery disconnect. Now only time will tell if this was the solution, or just a temporary fix. I hope it will stay working ofcourse.


All times are GMT -5. The time now is 09:01 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community