Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f162/)
-   -   a few '14 issues (http://www.jeepgarage.org/f162/a-few-14-issues-61406.html)

mattythreeputt 06-13-2013 09:02 AM

a few '14 issues
 
Anyone else experience the below:

1. Keyless Entry barely works. Sometimes not at all..... You have to use the fob. The button on the door handle is very hit and miss.

2. Instrument Cluster would not come on for me once. I had to get out lock the doors, wait a minute, get back in and it worked....

3. A/C seat doesn't seem to cool as much as my '12, but that could be in my head. They have a high/low setting, but i can feel no difference.

4. Sometimes the radio cluster freezes and does not respond to imputs. then all of a sudden it tries to catch up to all the buttons i was pressing while frozen. Like a bogged down computer.

I really like the '14 over the '12, but I'm a little worried about the electrical glitches so far...

BobsWK2 06-13-2013 08:27 PM

Re: a few '14 issues
 
It's gonna take some time for Chrysler to address the electrical gremlins on the 2014's. Obviously not enough time went into R&D on the Uconnect and new electrical architecture system in the 2014's.

VermontJGC14 06-13-2013 08:32 PM

Re: a few '14 issues
 
When did you take delivery? Mine that I picked up a few days ago has been flawless in those particular areas, especially the keyless entry - it has worked every time w/o fail. My radio reception cuts out once in a while, but only in XM, while it is apparently hunting for a signal (I drive through fairly remote, mountainous areas frequently).

bill_de 06-13-2013 08:35 PM

Re: a few '14 issues
 
One problem I had with the buttons on the handle turned out being my fault. I was accidentally letting my fingers touch the back of the handle while pressing the button. The system couldn't tell if I was locking or unlocking. Maybe keeping your fingers out of the way will help with one of your problems.


---

white6.4 06-13-2013 08:44 PM

Ive had the keyless entry issue when i try to lock the door....usually use the key fob instead

Jetcop20 06-14-2013 05:51 AM

Re: a few '14 issues
 
Take it in to your dealership...my door handles work great for lock or unlock (Fob just dangles from belt):thumbsup: Theres no break-in on electrical connections there either tight/loose so take your concerns to service manager:thumbsup: I'd like to say a BIG thank you to the crew in Detroit who put my '14 SRT together..everyday I'm looking at it and driving it with FLAWLESS results:cool:

white6.4 06-14-2013 10:10 AM

Yeah im gonna take it when i get my oil changed ill have the key in my pocket standing next to the door and it has trouble lovking the car when i press the door handle button most of the time other times it works fine its a 70/30 splitt with 70% of the time not working how it should...

mattythreeputt 06-14-2013 02:29 PM

Re: a few '14 issues
 
Exactly my problem.

marosenb 06-14-2013 02:42 PM

Re: a few '14 issues
 
Quote:

Originally Posted by mattythreeputt (Post 840825)

2. Instrument Cluster would not come on for me once. I had to get out lock the doors, wait a minute, get back in and it worked....



That is how my issues first started. Had about 300 miles on my JGC, and one day, the cluster would not come on. Right after that, I had serious issues with it (like the engine shutting down while in motion)...

Make sure you take it to the dealer, have them check all the grounds, and hopefully they fix the cause before the electrical issues start impacting more systems.

radbushi 06-17-2013 02:13 PM

Re: a few '14 issues
 
Quote:

Originally Posted by white6.4 (Post 841273)
Ive had the keyless entry issue when i try to lock the door....usually use the key fob instead

The proxemity key has to be really close.

LI SRT 06-23-2013 05:21 PM

Re: a few '14 issues
 
I have a different issue with the RKE when locking. About 5-10% of the time, I'll push the button on the handle to lock, the doors lock, then I get three beeps and the doors unlock. Seems like it thinks the fob is still inside the passenger compartment.

houtex 06-25-2013 09:31 AM

Re: a few '14 issues
 
I hate to say this but, I'm considering getting rid of the SRT.

First problems I had were the AC and the bluetooth.
Now the rear brakes squeel, my dash did not come on yesterday and the carbon fiber inside came up.

I work nights, 10 hours most nights and I live out of the way of my dealer. My service exp. so far has sucked.

I know that they are 2 totally different trucks but I never had a issue with my 2008 Tahoe LTZ.

For 65k I expect a little more.


All times are GMT -5. The time now is 03:43 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community