Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Visual/Navigation (http://www.jeepgarage.org/f155/)
-   -   UConnect Problems Quick List - Solutions and Notes (http://www.jeepgarage.org/f155/uconnect-problems-quick-list-solutions-and-notes-61569.html)

Willx 06-17-2013 10:52 AM

Updated: June 17th 2013 5:01PM EST

Hello everyone,
Thought I would make a little quick list of items that I have found out and summarize them in one reference place for the 2014 Jeep Grand Cherokee Infotainment systems. I am trying to make this as short form as possible to get the information out, but there is a lot of info. I will edit some quick links in the bottom for reference to the updates post and anything else I can come up with that is important.

-All phones (Android and iPhone included) have some issues syncing the entire address book. The cause at this time is unknown. I have not been able to duplicate this myself but have seen a lot of people with this issue. I assume it is related to something funny in the address books themselves as two exactly the same phones may or may not sync the entire address book. Mine is 1200 Entries and comes back with 970 which is all the ones with phone numbers so it appears to not be size.

-Bluetooth Audio Playback seems to skip occasionally on the Samsung Note 2, this appears to be the only phone that has this issue. If you are having skipping or disconnect issues with BT on your phone, make sure the in the Audio list it is set to number 1 priority for the one you use the most. If it is number 2 and the system sees the other phone at some point it does sometimes disconnect. There are 2 priority lists for media (one for phone one for media player). If you continue to have issues with playback remove your phone from UConnect, delete the UConnect Bluetooth from your phone as well.... Sync the Phone but this time DO NOT allow the radio to connect to the phonebook. Stopping the Phonebook sync will correct some playback and flakiness issues. I expect this to be resolved in a future update.

-If you have complaints about the volume difference between your SAT radio and your Bluetooth device, adjust the volume on your BT phone while it is connected to the Radio. This also applies to phone volume. Android Version 4.2.1 and later seem to remember the bluetooth volume properly, earlier versions of Android appear to be hit and miss as it sees Bluetooth as being related to the headphone output.

-The iphones seem to have a shorter transmission range and are more prone to interference than some other devices tested. if your iPhone is cutting out while using Bluetooth, I suggest placing it under the screen. Seems to completely correct the issue. The Problem seems to be worse on earlier iPhones but I had a 5 do it to me while sitting on the passenger seat.

-The Bluetooth Connectivity is Better on the 13.15.4 Release of the software for the 8.4A and 8.4AN radios. Connecting, switching and using any Bluetooth device appears better. There are also Navigation speed improvements with this update. If you are running the 5" radio there is a specific update that addresses loss of Bluetooth connectivity after restart. There is a STAR Case refering to this issue.

-The UConnect supported phones list on their website is miserably out of date and pretty useless. If you are buying a new phone today it WON'T be on the list so don't get hung up here. Every current smart phone I have tested (Including the Galaxy S4) appear to work as well as any other phone out of the box. There are some issues which I believe will be improved upon with future UConnect updates but also some APPS on your phone and Phonebook/Contacts issues on your phone may be causing the problem. If you get a new phone, try it on the system with some sample songs and just the calling feature first BEFORE restoring all of your stuff. This will give you a good idea if there is something you have put on your phone that has stopped it from working.

-UConnect APPS are doing "something" in the background often and has caused some odd things on some radios. This does seem to happen in spurts and affects everyone around the same time. I do not have an Activated system so I cannot verify these complaints, however there is a trend in when they happen. There was a report from at least 2 members that re-installing the 13.15.4 update on their radio cleared up some of the rebooting issues that "appear" to be connected to the APPS. The update installs some base profiles for these apps during the update so it is possible that there were some fixes, again I cannot verify this information. Re-Installing the update has also fixed a voice control problem.

-The USB port on the System appears to be a high power port which can charge an IPad. This is notable as most computers can't charge an IPad so I would say this is an excellent charging medium for your cell phone. You can connect directly with USB with most phones I have tested.

-Side note on the Auto Air not coming back on when using the remote start feature. This seems to affect most vehicles but does not appear to be corrected in the 13.15.4 update of UConnect (HVAC controls are part of UConnect updates so I will lump them in here). As 13.19.0 is in shipping product now I will test the remote start as soon as I get a chance. If there is no update on this line there is no change but I will keep an eye on this.

-Some people have noted their gauge cluster coming back to life when not near the vehicle or with Fobs nearby. It is an educated guess that either there is something going on update wise via UConnect or that there is a wireless interference issue causing the vehicle to "wake up" and see if there is a fob present. These are just theories at this time, but still looking at these.

Most Current 8.4A and 8.4AN updates available at time of post: http://www.jeepgarage.org/f155/uconn...tml#post827863

Willx 06-17-2013 12:46 PM

Update: 13.19.0 version of UConnect now shipping on vehicles.

gigi_boy_156 06-17-2013 02:51 PM

Willx,

do you know, when the new file will be available for downloading?

-Gigi

SnoFire 06-17-2013 03:00 PM

Re: UConnect Problems Quick List - Solutions and Notes
 
Willx...You keep making this valuable information for all users...Thanks again for really moving forward with this and trying to help everyone.

Willx 06-17-2013 03:06 PM

Quote:

Originally Posted by gigi_boy_156 (Post 843391)
Willx,

do you know, when the new file will be available for downloading?

-Gigi

I don't know that. The versions work in 3 steps by point value. The first digits are the major release, the second digits are the features or changes and the last two are patches and fixes. As this is a .0 release I would expect they will still be making some tweaks before a public release. Also they are in the midst of fixing their servers as the dealers can't even get access to the files right now ( why the users got shut out recently ). All of this and I would guess it will be 30 to 60 days to public availability but if I see it at a dealer I will get it for you guys.

gigi_boy_156 06-17-2013 04:02 PM

You're the best!

psujeeperman02 06-17-2013 04:49 PM

Is it possible to update the RES radios?

Willx 06-17-2013 06:19 PM

Re: UConnect Problems Quick List - Solutions and Notes
 
Quote:

Originally Posted by psujeeperman02 (Post 843456)
Is it possible to update the RES radios?

That I don't know, I took a quick look I dont see anything. There are some Threads on the RER etc, you may wish to post there. I am not as familiar with the other units. Sorry :(

vedled 06-19-2013 12:19 PM

Re: UConnect Problems Quick List - Solutions and Notes
 
Regarding bluetooth connectivity, I was having issues with Uconnect picking up my BT connection to my Galaxy S3. Sometimes it would, sometimes it wouldn't - although my phone ALWAYS showed that it was connected to Uconnect. A simple disconnect and re-connect of the BT connection from my phone and all was fine. I removed all other bluetooth pairings from my phone so that Uconnect is the only paired device and have not had a problem since. Vehicle picks up my phone EVERY time automatically. Granted, this is a pain when i have to re-pair my bluetooth headset every time i want to use it but i don't use it that much.

Maybe that little tidbit can help somebody else until they release another Uconnect update to fix all of this stuff.

vedled 06-19-2013 12:21 PM

Re: UConnect Problems Quick List - Solutions and Notes
 
I still can't initiate phone calls from Uconnect despite being able to receive calls and texts. As long as i initiate the call from my phone, i can hold the call through the vehicle. Just won't actually dial through Uconnect....weird. I thought it worked prior to the Uconnect update. Not sure what the deal is there...

Willx 06-19-2013 02:07 PM

I will add this.... if you do a UConnect upgrade or your software gets updated on your phone, make sure to delete the pairing from both and re-pair. Seems silly but I see this problem on lots of devices after an upgrade.

Also make sure your phone is set to the highest priority on the Phone list.

Willx 06-20-2013 08:05 PM

Re: UConnect Problems Quick List - Solutions and Notes
 
Can't edit my original post but I would like to add that at least one user has confirmed that the Galaxy S4 works with all features including the messaging. My new go to phone.


All times are GMT -5. The time now is 03:46 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community