Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Visual/Navigation (http://www.jeepgarage.org/f155/)
-   -   Willx Report - UC 13.19.0 - VR Problem (http://www.jeepgarage.org/f155/willx-report-uc-13-19-0-vr-problem-62098.html)

Willx 06-28-2013 10:52 AM

Hello everyone,

I have an interesting discovery that I wish to share but I am not really sure the causes etc, so try not to read into this too much but more from a "possibly this may fix your UConnect Problem" standpoint.

I borrowed a 2014 Summit Hemi with 8.4AN (RA4) to start doing some other testing including a hauling test later this weekend. As usual, I am trying all kinds of things you guys talk about here because this is yet another new Jeep (June week 1 build) and it came from the Factory with 13.19.0, so very current.

I was attempting to go to a client project and was using VR to tell the NAV where I wanted to go... I would press the VR button it would tell me it is "listening" and I would say "Enter Destination", it would not say "processing" and the "listening" message would go away. Sometimes it would time out and say canceled, sometimes it would just sit there like a dumb $h1t and not even flip back to my media. So here are the steps I went through below

1. Full stop, vehicle off, open door - restart
2. Disabled Paried Bluetooth Devices
3. Full Stop vehicle off and locked for over an hour - restart
4. Performed Microphone clarity tests with multiple 3rd parties via bluetooth connected (Ironically I am told I am loader and clearer in the Jeep than any other vehicle I drive by 2 different sources I talk to all of the time so ++ Jeep on this part)

None of these had any impact on the issues I had with VR, it did not understand or even acknowledge any of my requests for various applications. Before you make fun of any accent I may or may not have, I use this all the time in various Jeep and Dodge products and I have never had an issue with this.

In having to pull over and enter the address with my fingers :eek: I noticed that the NAV seemed a little slower than normal. I will do further testing on this later but for now it is simply noted and may just have been my frustration at the time.

** The Fix **

As I have learned from others here after an upgrade, that certain minor issues were corrected after a reload. Now this may be because this is one of the rare times the system has to reload from a new state so it is possible this could have been fixed by a radio reset.

I will repeat though this is a FACTORY load of 13.19.0 so I find it really odd but I reloaded from my USB stick of 13.19.0 and guess what VR now works PERFECTLY. My initial impression of this is confusion as it seems a little unusual that this was not correct from factory however this may have been a post assembly or at facility upgrade on the radios due to known issues with past software revisions.

I have never received any warnings to service the radio or any indication that the initial load had an issue at all. During my reload it asked if I wanted to upgrade 13.19.0 to 13.19.0.

So from the start of my note here, this is basically nothing other than a long winded proof that IF you are experiencing an issue with an application on the radio that reloading the EXACT same software may correct the problem. This has been talked about a few times and I can say without a doubt that VR was not operation in my test vehicle and is now after a reload.

THX for reading the Willx Report :thumbsup:

kbrown127 06-28-2013 08:34 PM

Re: Willx Report - UC 13.19.0 - VR Problem
 
Thanks, I actually had this VR issue after my update. I just re-loaded 13.19.0 a second time and initial tests indicate the issue is fixed. Very helpful post Willx and thank for posting the updated software

Willx 06-28-2013 09:27 PM

Thank you, glad to hear I can get confirmation on what I did. More importantly it fixed a problem for you.

SleepyWeasel 06-29-2013 07:01 AM

Re: Willx Report - UC 13.19.0 - VR Problem
 
I had posted up in the other UConnect thread about my issues. I had the head unit replaced yesterday at the dealership. It has the current 13.19.0 software. When it was done, I sat in the parking lot configuring my settings. I tried the VR and had the same thing happen. I went back into the service department, had the tech come out and verify it wasn't working. After working on it for an hour, they came back out and said they had talked with Chrysler and Chrysler said to replace the head unit again. So it seems to me that even Chrysler doesn't know a damn thing and that you, Willx should be handling this for them and the Chrysler doesn't bother reading the forums to find solutions to their problems that other people have. Now, I need to find a copy of the 13.19.0 software to fix my issue.

SleepyWeasel 06-29-2013 07:35 AM

Re: Willx Report - UC 13.19.0 - VR Problem
 
Found it. Let's go see what happens.

fumblefingers1 06-29-2013 07:39 AM

Re: Willx Report - UC 13.19.0 - VR Problem
 
Thanks for the info, This is a very interesting post. Most of us are familiar as to how MSFT downloads fiirmware with part installed then the computer must shut down and reboot to install more software that is dependent on the first software code.

Since I don't have any information about what is happening at the factory but do understand that Jeep has added a 3rd shift, I suggest that there may be a possibility that assembly workers are not adequately trained and not installing the firmware in a proper sequence.

Software engineers think in different terms than assembly workers. I learned a long time ago....."when all else fails, read the book"

Willx 06-29-2013 07:58 AM

Re: Willx Report - UC 13.19.0 - VR Problem
 
Well Thank you for the vote of confidence...! When I actually have a unit in front of me doing something wrong, it is easier for me to diagnose. Let me know if you need further assistance. The new head unit will likely fix your issues as the newer hardware seems to be better.
I have attempted to report the issues I know of upstream but my communications are indirect, so we will see?

fumblefingers1 06-29-2013 08:21 AM

Re: Willx Report - UC 13.19.0 - VR Problem
 
Quote:

Originally Posted by SleepyWeasel (Post 850216)
I had posted up in the other UConnect thread about my issues. Now, I need to find a copy of the 13.19.0 software to fix my issue.

Good Luck.... Does UCONNECT have a site where U can download the firmware to a USB flash? I ordered a RA4 I am hoping that the issue will be resolved by the time my new ride starts down the line. It has been sitting at D1 for a couple of weeks now and dealer estimates July 20 delivery. I will believe that when I see on the VOTS movement to frame.

I may have made a mistake ordering the Jeep from a delaler at my former home 800 miles away from my current residence. I decided to select that dealer due to the fact that I had purchased 3 other vehicles and they always treated me right. When I moved the local Dealer that I liked had Jeep yanked from them during the auto bailout and I am not enamored by the replacement dealer. :(

SnoFire 06-29-2013 08:27 AM

Fumble... The assembly workers at JNAP are not the ones doing the software/firmware of the radios, this is done at the factory that makes the radios so Jeep is at their mercy. Yes it sucks that if you have problems your great dealer is 800 miles away but I would guess there is a dealer somewhere close that is better than the one you would rather not go to.

fumblefingers1 06-29-2013 08:47 AM

Re: Willx Report - UC 13.19.0 - VR Problem
 
Quote:

Originally Posted by SnoFire (Post 850261)
Fumble... The assembly workers at JNAP are not the ones doing the software/firmware of the radios, this is done at the factory that makes the radios so Jeep is at their mercy.

Thanks. I assumed incorrectly that the radios already in inventory at the assembly plant had to be updated by the assembly line specialty shop rather than shipping them back to UCONNECt even if UCONNECT was in Detroit. Isn't UCONNECT a subsidiary of Chrysler?

Willx 06-29-2013 08:51 AM

Re: Willx Report - UC 13.19.0 - VR Problem
 
Adding to Sno's Comment.... Fumble, the radio may come with 13.19.0 or it may come with a version none of us have seen yet. I expect to see another update early in July but it may be more wireless with apps etc then other things. Also you should read Post 1 carefully on this thread the entire purpose was to point out that the version may not even be the issue, that the customer re-loading the exact same version may fix problems (and not just VR).

I Should point out I am not "really" a programmer, I am more a technical translator (I understand Crestron and AMX programming not specifically cars). In the past I have worked along side programmers and developers to diagnose problems on similar interfaces to your vehicle and do what I am doing here. I am not using special tools and dealers are not directly involved in any of the work I have done with these radios. I use diagnostic skills to understand the problems but the software update process etc is very user friendly... In Fact the most user friendly I have used in a vehicle. I would say by the time you get yours that your radio hardware will be nearly as good as it is going to get from what has been learned. Any updates down the road will be easy to do, so no worries.

Lastly, find a dealer close to you with a service department that looks after you. You only need to negotiate with sales once in a Blue Moon... You need a service department that takes care of you, and you will likely buy your next vehicle there because of it. Sno is dead on here I am sure there are a few closer. just stop by and walk into the service department and see if you are greeted properly, that is the first indicator of a good store.

Willx 06-29-2013 08:54 AM

Re: Willx Report - UC 13.19.0 - VR Problem
 
Quote:

Originally Posted by fumblefingers1 (Post 850265)
Isn't UCONNECT a subsidiary of Chrysler?

No UConnect is a sort of group in a company that designs and impliments software for vehicles. UConnect is the branding that Chrysler chooses to use but this stuff is mostly done by that third party.


All times are GMT -5. The time now is 11:36 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community