Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee SRT - WK2 (http://www.jeepgarage.org/f97/)
-   -   Service 4 wheel drive and ABS light (http://www.jeepgarage.org/f97/service-4-wheel-drive-and-abs-light-62294.html)

14StormTrooper 07-02-2013 05:10 PM

Service 4 wheel drive and ABS light
 
Just had my eibach springs installed and new pads all around. My truck has service 4 wheel drive and service ABS in the messages. Anyone else have this issue?

14StormTrooper 07-02-2013 05:23 PM

Also my park assist sensors need service too. Anyone with 2014s had this issue?

Artofnoize 07-03-2013 08:47 AM

I didn't have any problems with mine Tom. I even replaced the stock rotors with Brembo drilled one's. Sounds almost like a harness got disconnected. I am guessing of course

14StormTrooper 07-03-2013 10:56 AM

Quote:

Originally Posted by Artofnoize (Post 852265)
I didn't have any problems with mine Tom. I even replaced the stock rotors with Brembo drilled one's. Sounds almost like a harness got disconnected. I am guessing of course

Took it to the dealership today. Speed sensor on one of the brakes is out. Will be in in a week.

lillyjas 12-17-2016 08:58 PM

Re: Service 4 wheel drive and ABS light
 
Just had the same thing happen to me on the way home from the airport in crap weather... looks like I will need to be taking it in


Sent from my iPhone using JeepGarage

Tinman4181 12-18-2016 04:21 PM

Re: Service 4 wheel drive and ABS light
 
Same thing happened on my 15 when I was on way home from dealer at purchase. Replaced wheel speed sensor and has been fine ever since.

lillyjas 12-19-2016 10:46 AM

Re: Service 4 wheel drive and ABS light
 
Damn-est thing... called the dealer to get in this morning... after sitting in garage all weekend... started up had all the lights and error messages... pulled out... and started driving and it all went away... drove 20 miles and never came on...

Maybe warmed up and some ice or something melted away? Or a sensor on the verge of going south?




Sent from my iPhone using JeepGarage

Tinman4181 12-19-2016 10:47 AM

Re: Service 4 wheel drive and ABS light
 
Quote:

Originally Posted by lillyjas (Post 2020176729)
Damn-est thing... called the dealer to get in this morning... after sitting in garage all weekend... started up had all the lights and error messages... pulled out... and started driving and it all went away... drove 20 miles and never came on...

Maybe warmed up and some ice or something melted away? Or a sensor on the verge of going south?




Sent from my iPhone using JeepGarage

Mine would do the same thing. When the dealer plugs it in they will see the codes. The sensor needs to be replaced.


All times are GMT -5. The time now is 05:39 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community