Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Sluggish patriot when brown grey smoke from exhaust (http://www.jeepgarage.org/f77/sluggish-patriot-when-brown-grey-smoke-from-exhaust-62549.html)

essjay 07-09-2013 06:26 AM

Sluggish patriot when brown grey smoke from exhaust
 
I have a 2008 2.0l CRD patriot. Last week the car started to "hiccup " when I accelerated and a cloud of brown/grey smoke was pumped out of the exhaust. Checked the engine and I discovered that a small hose which attaches to the air filter box was not attached ( I assume this happened at its last service two months earlier) I reattached this but it made no difference. Last night I checked the air filter and mass air sensor which look clean but the air after the mass air sensor looked like it had oil deposits on the sides (dry residue ). I also added some fuel clearer to the fuel tank. This appear to stop most of the "hiccup" but smoke was still appearing after the engine was reved. The journey to work this morning however presented another issue the cars was not as responsive and lacked power. Has anyone got any ideas. The car has 50k on the clock, it doesn't appear to be losing oil or water and it starts first time. There are no warning light illuminated on the dash.

essjay 07-12-2013 06:37 AM

Just had the AA man look at the car and it appears to be a fault with the EGR valve, he has blocked the inlet and the car appears to be working fine. Clearly I will need to address this issue before the MOT. As anyone got experience of cleaning the EGR on a Patriot?

essjay 08-19-2013 05:13 AM

Quote:

Originally Posted by essjay (Post 857022)
Just had the AA man look at the car and it appears to be a fault with the EGR valve, he has blocked the inlet and the car appears to be working fine. Clearly I will need to address this issue before the MOT. As anyone got experience of cleaning the EGR on a Patriot?

Not the end of the story towed the caravan to Scotland and an error code appeared regarding the turbo, plus car lost power. Once I was towed home at the cost of 300 I had the EGR valve replaced only to discover that there was also a hole in the turbo hose, busy trying to source another but in the meantime I've effected a repair using self amalgamating tape plus brass wire once is working


All times are GMT -5. The time now is 04:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community