Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   2014 GC laredo Antenna problem (http://www.jeepgarage.org/f107/2014-gc-laredo-antenna-problem-62678.html)

at88 07-11-2013 09:11 AM

2014 GC laredo Antenna problem
 
I got a new 2014 gc loredo about a week ago and I am constantly hearing a static/pop noise from the radio. It only happens on the radio stations and not CD or bluethooth so im pretty sure its the antenna. And also, If the car is not moving it sounds perfect, but as soon as you move it starts again. Is it possible that the antenna is loose? and also is there a way to take off the shark fin and tighten the antenna?

Dave in Pa 07-11-2013 06:30 PM

Re: 2014 GC laredo Antenna problem
 
I do not have an answer for the fix but my 2014 has done this since day one ONLY when using the AM radio band. If a storm is coming or maybe a bad reception area it "cracks" sort of like a 22 rifle going off. At first I thought I was going batty! At my 1st oil change a few weeks ago I asked my "service advisor" & his comment was it is AM radio & they usually suck anyway?!! SO I am not sure what I will do yet; and I have never heard anything like it before. Dave

blackknight 07-11-2013 09:21 PM

My A M radio does the same thing. I use to listen to AM a lot but it is almlost impossible in this jeep unless the signal is really strong.Also the XM cuts in and out a lot. This is one of the poorer radios I have ever had as far as reception is concerned.

GCL2014 07-26-2013 07:24 PM

Re: 2014 GC laredo Antenna problem
 
Unrelated question regarding the antenna.

Is the antenna supposed to be painted the same color as the body or is it normally black?

GCL2014 07-26-2013 07:36 PM

Re: 2014 GC laredo Antenna problem
 
This is for a GC Limited. Not sure if it matters based on trim level.

morfred 08-05-2013 09:53 AM

Re: 2014 GC laredo Antenna problem
 
My '14 JGC radio is almost impossible to listen to because of pops and static on AM stations. Seems to be near city power lines? Any else having this problem or anyone have a solution. Right now I pretty much have to stick to FM.


All times are GMT -5. The time now is 11:26 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community