Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Need y'all's opinion (http://www.jeepgarage.org/f77/need-yalls-opinion-63196.html)

La-Bestia 07-23-2013 09:43 AM

Need y'all's opinion
 
So about 4-6 months ago I put a new jet 180 on my jeep right. The truck was riding cool as usual, probably around 190 most of te time. I noticed last week that my jeep was running warmer than usual... Reaching up to 215-220. So yesterday I stepped on the throttle a little bit on my way home, and then I noticed my needle was rising until it got out of control and I pulled over. Sure enough the jeep was heating up tooooo much!! reached all the way up to 245. I did what I was always told. Checked the fluids and they were fine. So I turned it off and let it cool down. Didn't add water because it didn't need any. Then I turned it on an added some water to the radiator because it was a little low. Noticed the engine sucking in air... Found that the hose from the radiator to the heads was loose and lost all the water, so I connected the hose back on. This is the small hose that goes to the therm. Added water and still heating up and boiling water out of the cap. Took the hose off and took the thermostat off. Added water and drove it home at 180 all the way! Does this sound like just the thermostat went bad? Since it was running hotter than usual the week before? Or could it be the head gaskets? :-/ I hope not!!!

VistaCruiser 07-23-2013 10:48 AM

Re: Need y'all's opinion
 
Probably stuck thermostat. Are you seeing any white smoke from the exhaust? Any signs of coolant/oil contamination?

Sam

La-Bestia 07-23-2013 12:57 PM

Re: Need y'all's opinion
 
Quote:

Originally Posted by VistaCruiser (Post 863291)
Probably stuck thermostat. Are you seeing any white smoke from the exhaust? Any signs of coolant/oil contamination?

Sam

No white smoke and no water in oil... Drive fine home once I took t-stat off and added water. Drive cold all the way home. (5miles) hoping its the tstat that got stuck

rob1019 07-23-2013 01:13 PM

Sounds like you just need a thermostat


All times are GMT -5. The time now is 04:07 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community