Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Power Steering Pump Hoses?? (http://www.jeepgarage.org/f107/power-steering-pump-hoses-63611.html)

Fmt662 08-02-2013 09:45 AM

Power Steering Pump Hoses??
 
So I walk out the door this morning heading to work, and as the remote start started my jeep I noticed that it sounded a bit odd. Then I walk around the corner and see that theres a bit wet patch under the car. At first I was thinking that it was from the sprinklers, but as I was looking at it I saw fluid start pouring out under the engine.

After turning it off I popped the hood and found that one of the power steering hoses had come off of the pump, and it had been pumping out.

Has anyone had this issue before? I think its wierd that it didnt happen while I was driving. Looking at the mess on the driveway it looks like it happened right when I turned off my car yesterday.

At the same time, I noticed that the engine doesn't look like it's quite in line with the car. Shouldn't it be perfectly longitudinal?

This on a '14 Overland Hemi 4x4. Makes me glad I kept my 1996 E-class.

swaldron5 08-26-2013 07:47 PM

Re: Power Steering Pump Hoses??
 
Yup. Same thing happened to me. Had to have it towed. Came back to my jeep and the top hose going into the pump was disconnected. I have a 2014 Limited w/ Hemi.


All times are GMT -5. The time now is 08:17 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community