Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   '14 Laredo Radio Issues (http://www.jeepgarage.org/f107/14-laredo-radio-issues-63870.html)

shthpns22 08-08-2013 04:24 PM

'14 Laredo Radio Issues
 
Anyone else with a '14 GC Laredo having issues with their radio? My radio periodically switches to AUX mode on its own, even though there is nothing plugged into the AUX outlet. The dealership said they haven't heard of this problem so they filled out a (star report?) Just wondering if anyone else has had this problem and had it fixed?

jeep5.7 08-08-2013 04:49 PM

Re: '14 Laredo Radio Issues
 
I just had the dealer update my 5.o radio,it kept freezing and a.c shutting off,new version installed,fine now

shthpns22 08-08-2013 05:34 PM

Re: '14 Laredo Radio Issues
 
Quote:

Originally Posted by jeep5.7 (Post 872111)
I just had the dealer update my 5.o radio,it kept freezing and a.c shutting off,new version installed,fine now

How long ago was that? The dealership said there was an update but it didn't apply to the radio I have, that was last week when I took it.

StaticFX 08-09-2013 08:06 AM

Re: '14 Laredo Radio Issues
 
Check the version you have: The newest is 13.19.0

shthpns22 08-09-2013 07:41 PM

Re: '14 Laredo Radio Issues
 
Quote:

Originally Posted by StaticFX (Post 872520)
Check the version you have: The newest is 13.19.0

How do you find out which version you have?


All times are GMT -5. The time now is 11:28 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community